6

I have installed an Ubuntu 14.04 VM with Virtualbox on Windows7,

When I lock my Windows session, then get back to it, Ubuntu session inside the VM is also locked,

How can I prevent Ubuntu VM from locking? (In any situation)

  • I've found that pressing [Win]+[L], when my Ubuntu session is focused in VmWare, locks both Ubuntu and Windows. My shortcut key in Ubuntu for locking is listed as [Ctrl]+[Alt]+[L] though.. Maybe you have problems with that as well. – thomasa88 Jun 9 '16 at 6:25
6

As thomasa88 suggests, the Win+L command to lock your screen will be received by both your host OS (Windows 7) and your guest OS (Ubuntu).

You have two options to solve this:

  1. While in your guest OS and wishing to lock your computer screen, navigate via the GUI to the host OS taskbar and lock the computer via the "Lock" option. This will prevent your guest OS from also locking.
  2. Change the keyboard shortcut for screen-locking in your guest OS. Follow this solution for Ubuntu: Remap Ubuntu keyboard keys

Here is a screenshot of the final step:

enter image description here

(I don't currently have sufficient reputation to add a comment, so I'm providing this answer.)

1

Go to:

Top right corner > System Settings > Brightness and Lock, and adjust the settings according to your needs.

This is done inside your VM.

  • Thanks for your answer, I've already tried that, but it didn't work. – YOBA Sep 25 '15 at 20:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.