I've set up a website with basic HTTP authentication. If I go there with IE 11 or Firefox 38, I get the expected dialog asking for credentials. If I attempt to go there with Chrome 45, it immediately gives me an "Authorization Required" error page and never asks me for credentials. This happens even after I restart the browser or the whole computer.

I've done the following things:

  • Set all of my security zones in my IE/Windows Internet Options to prompt for username and password, as I understand that Chrome for Windows uses those settings.
  • Tried making sure popups are enabled for the host I'm going to.
  • Checked to see if maybe incorrect credentials were saved (there are no saved passwords for the host I'm going to).
  • Dug through the Settings page for Chrome itself and found nothing else useful.
  • Going to the desired address and putting the credentials into the URL (http://user:[email protected]/page.html).

No dice yet, I'm about to pull my hair out.

I'd like to note here that, for one, I cannot give the URLs I'm trying to access, as they are not public. Two, there are some domain-based policies put into place and I can't change some settings in Chrome (this is a corporate machine). I'm wondering if there's something I've missed that could, at the very least, explain why it's doing this?

4 Answers 4


...And right as I finished writing this, I stumbled on something I DID miss. It looks like the policies set by my domain administrators have Chrome's AuthSchemes policy set to just negotiate, so it just doesn't bother with basic authentication. Looks like I need to talk to the IT department...


I had a similar issue, but was having trouble locating where Chrome stores this setting. On OS X, it's in ~/Library/Preferences/com.google.Chrome.plist.

You can check if you're impacted by this by reading the AuthSchemes key:

defaults read ~/Library/Preferences/com.google.Chrome.plist

If it is an IT policy, it will get re-applied, but you can test if this is the issue by making sure AuthSchemes is set properly and restarting Chrome:

defaults write ~/Library/Preferences/com.google.Chrome.plist AuthSchemes basic,digest,ntlm,negotiate

  • This fixed it for me in chrome 94 where it happened all of the sudden. 5 years after this answer was posted. I wonder why Chrome suddenly decided to change something there?
    – philk
    Oct 11, 2021 at 21:46

I had a similar issue, Chrome didn't show save dialogue after I entered basic auth on a specific website. However, it did save login/password from the actual website I visited. I resolved this issue by deleting the existing login/password for this website from "Settings > Manage Password" and restarted Chrome. After this, the save dialogue for basic auth showed up.

I think this happens when you have a saved password on a website and add a basic auth later.


To clarify, this is what a basic auth prompt looks like:

enter image description here

Group Policy settings for Chrome and Edge:

enter image description here

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .