0

My laptop HP Pavilion G6-1068SE has Intel HD 3000 On Board Graphics along with 1GB discrete Radeon HD 6470M graphics.

When I did a fresh install of Windows 10 x64, Windows Update automatically installed latest Catalyst Control Center along with the necessary display drivers for Intel HD 3000 (On-board Graphics).

What I expected under display adapters in Device Manager:

  • AMD Radeon HD 6470M Series
  • Intel(R) HD Graphics

What's actually present:

  • AMD Radeon HD 7400M Series
  • Intel(R) HD Graphics

Problems I face due to this:

  1. No 3D setting or any other configurable options in AMD Control Center (Information is the only tab available)
  2. No SWITCHABLE GRAPHICS options under context menus and in Control Center
  3. Discrete GPU Frequency constantly remains at 0MHz (from AMD System Monitor and tried other GPU benchmarking tools)
  4. All applications are fully and solely handled by Intel HD 3000 and discrete graphics is never detected by any of my games
  5. DxDiag shows DirectX version as 10 even though the laptop supports DirectX 11

Solutions I tried:

  1. Uninstalled AMD Catalyst Control Center automatically installed by Windows and tried following versions download from AMD website: v15.8 Beta, v15.7, v14.9, v14.4, v13.12, v12.10 and all of them showed the same problems. Note: Before installing each version I completely uninstalled the existing version rebooted and installed the other one.
  2. Went to HP Website, Driver for Windows 10 is unavailable. Downloaded Windows 7,8 and 8.1 drivers and installed in compatibility mode.
  3. Tried LESHCAT drivers downloaded from their official site.

In spite of all my efforts, the aforementioned problems still persist. Isn't there a way that I get my discrete GPU working with all features including switchable graphics in Windows 10, other than downgrading my OS to Windows 8 or Windows 7 so as to get drivers from HP?

Any help would be greatly appreciated.

0
  1. Update Bios and check new bios features referencing switchable graphics

  2. Uninstall both drivers and completely remove files, restart

  3. install the intel driver from their site not HP. restart

  4. Install the catalyst driver, it will (should) now pick up the instruction set for switchable ability and that should now populate in menus.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.