0

I recently installed Ubuntu 15.04 in an external hard drive (let's call it HDD2), with an Acer Aspire E1-572G. It already had installed Windows 8.1 on its internal hard drive (let's call it HDD1).

During the installation, I'm pretty sure that I chose HDD2 to install the bootloader, but now when I try to start the laptop with HDD2 unplugged, I get that nasty GRUB shell, saying:

GNU GRUB version 2.02~beta2-22ubuntu1.1

Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device or file completions.

If I run exit, the laptop's BIOS boot option menu appears, letting me choose between:

  1. ubuntu (which actually brings me back to GRUB's prompt)
  2. HDD (wich boots Windows)
  3. Windows Boot Manager (wich boots Windows, too)

Already tried

  • Using the recovery tools on an installation drive: I tried booting into a pendrive with the Windows 8.1 installer on it, but the computer didn't recognize it (not even on the boot menu options, and I've done it MANY times before, with the same ISO).

  • Using the recovery command prompt: also tried running bootrec /fixmbr, bootrec /fixboot (both finished successfully), bootrec /rebuildbcd (which detected 0 Windows installations), and bootsect /nt60 C: (with success). Also all of them together, separate, in different orders and combinations...

  • Using the recovery command prompt (by kelef): from the recovery command prompt (not the installation media one), I ran bcdedit /set {default} device partition=c:, bcdedit /set {default} osdevice partition=c: and bcdedit /set {bootmgr} device partition=c:, all of them successfully.

(I'll update the list as you suggest me new things to do)

I'd like to point that formatting is not an option, and that I still can access my Ubuntu installation if I plug in HDD2 (I just get the normal, purple GRUB screen where I can choose between Ubuntu, Windows, and that stuff).

0

hei'ya Hewbot, my 2cts worth- use Hirens boot cd- boot from cd or usb> mini windows xp> hbcd menue> partition/boot/mbr> command line> mbrfix> input"MbrFix /drive 0 fixmbr /win7 /yes"> then "exit" > restart system after removing cd/usb and boot from c: hope this helps- kelef

edit: oops might not apply to win8 didn't read correctly - me bad

edit edit: maybe try at X:\Sources> enter "bcdedit"> displays settings and then enter to confirm choices

bcdedit /set {default} device partition=c:

bcdedit /set {default} osdevice partition=c:

bcdedit /set {bootmgr} device partition=c:

the other automated possibilty is: X:\SourcesRecovery >StartRep.exe

  • 1
    Please edit your answer and fix the spelling mistakes and grammar. There is also no need to add "edit:" and edit edit:" when making changes (it just makes the answer confusing). At the moment it is very difficult to understand exactly what you are trying to tell us. – DavidPostill Sep 27 '15 at 8:26
  • Tried all of that (except Hiren's boot, since you said it might not apply), and I was able to run everything except StartRep, since that's in the installation media and I'm not able to access it, as stated in the question. Still happens the same. Also, (and as a constructive suggestion), I'd organize a little your answer, because it's a bit messy, as @DavidPostill notes. – Hewbot Sep 27 '15 at 17:27
0

I finally found a (working, but not really ellegant) way to fix this:

Went to the BIOS' boot order settings, and placed the hard drive (which surprisingly had been renamed as ubuntu[my hard disk model]) in first place.

Honestly, I don't really know why did this work, and probably GRUB is still somewhere in the laptop, but I dont' really care, BTW. Just keep it in mind, if anyone is going to try this in the future.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.