1

I've been struggling to revert my windows login from a microsoft account to a local account. There are many tutorials on the web but the solution presented involve an option that I cannot see:

I'm supposed to got to:

Start->Settings->Accounts->Your Account and click on "Sign in with a local Account instead"

enter image description here

My problem is that I cannot see that option!

How can I solve this? tks.

0
  • First, simply make sure your account is an Administrator

  • Second, check to see if signing in with a Microsoft account is disabled using local security policy

    1. Win+R and type gpedit.msc
    2. Head to:

      Computer Configuration -> Windows Settings -> Security Settings -> Local Policies -> Security Options

    3. Find the policy called: Accounts: Block Microsoft accounts

      This policy setting prevents users from adding new Microsoft accounts on this computer.

    4. Make sure the policy is set to: This policy is disabled

  • Try to run a system integrity check

    1. Type "cmd.exe" in search and then press Ctrl+Shift+Enter to open an elevated command prompt
    2. Type sfc /scannow to verify and attempt to fix windows integrity issues
| improve this answer | |
  • I've followed your tips but unfortunately it didn't work. I'm still not able to see the local sign in option. Thanks anyway. – CONvid19 Sep 28 '15 at 2:10
-1

Note: If you have not already tried to make your logon local by going to account settings described in paragraph 3 below. Do that first, if it doesn't work, then go to Group Policy.

1) My Local Group Policy (gpedit) screen was a little different, but I figured it out. It goes: Local Computer Policy> Computer Configuration> Windows Settings> Security Settings> Local Policies> User Rights Assignment. From there, there are a long list of policies. Go to 'Deny log on locally,' left click and click on properties. Mine had a long identification set, which I removed. It also had 'guest' and that should probably be removed as well. Open the Explain tab and it will explain it all. The default for that setting is None.

2) There are also instructions on this page to block access. To get there take almost the same route- Local Computer Policy> Computer Configuration> Windows Settings> Security Settings> Local Policies> Security Options>Accounts:Block Microsoft. Access the same as above and carefully read the Explain Tab. After doing so myself I was leery of making changes. It wasn't necessary in order to change back to Local logging on. It may be in order to keep it local, but I want to be able to work online if I want to, but after I have logged on to my computer. So I am still considering if I will change this one from the default.

3) Having made the changes, Open Control Panel > All Control Panel Items > User Accounts and click on 'Make changes to my account PC settings' There should be the option to sign in with a Local Account. Click on that and follow the prompts. You will need to start out with the MSN password and then it will ask you to choose and enter your local password. It will reboot, so before you do this, close anything that is not saved because it will log off.

What has me puzzled is how the User Rights Assignment. got changed. I was logging on locally, then last night I shut down and today it had reverted to the MSN logon. The first time it changed over easily to local access. without all of this, this time it didn't go so easily. Good thing I have an old Vista computer where I keep a copy of my password vault.

| improve this answer | |
  • This does not appear to work on Windows 10 Home Version 10.0.17134 Build 17134. The option to "sign in with a Local Account" never appears. Also, step 1 and 2 above seem haphazard and unnecessary when trying to solve the problem originally posed in this thread. – ShieldOfSalvation Jan 28 '19 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.