My multiboot USB drive (that also is used as a normal USB) isn't quite working properly. By this, I mean I can't get a computer to realize that it's a USB flash drive. The closest I've gotten is under an Ubuntu Live OS, I can search for "Drive" in the dash and pull up the list of drive devices or whatever the exact wording is. It sees everything else as it should, all my partitions etc, and then it sees my USB. It doesn't give an option to do ANYTHING of usefulness, as it says "no media" in red instead of giving an option to mount it. It's listed here as "XXXXXXXX U168CONTROLLER" if that's of any help.

Fdisk doesn't find it. lsblk doesn't find my device. lsusb returns

Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 003 Device 002: ID 046d:c32b Logitech, Inc. 
Bus 003 Device 003: ID 046d:c24c Logitech, Inc. 
Bus 003 Device 006: ID 041e:323c Creative Technology, Ltd 
Bus 003 Device 005: ID 1b1c:1a95 Corsair 
Bus 003 Device 007: ID 048d:1168 Integrated Technology Express, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

But don't get your hopes up, while it does show a Corsair device, that's a second USB that I'm using to run the live os off of. It's a 32 GiB drive, and the drive with said issue is 64 GiB. So that's my issue.

Now on to what could've caused it...

Theory one: I was in the process of installing Arch once again on my desktop, this time using UEFI and GPT instead of BIOS and MBR. I was setting up partitions with parted, and I think that's what caused my issue, but I AM NOT sure of this, nor does it make sense to me. The reason I think this caused it is as follows: I am working on formatting my HDD to setup home, boot, and swap values. I already have home and swap in place, so I was working on adding the boot partition. I shrunk what I thought was the home, and added what I thought was the boot. It's possible that this wasn't in fact the HDD, but instead it was my multiboot USB, despite the fact that I was working on /dev/sda which contains my Winderp$ partition, as well as Arch partition. USB should've been /dev/sdc at the time, with /dev/sdb being my SSD.

Right after shutting down my live USB, the drive stopped responding to anything. Tried on 4 different computers and 6 different operating systems, with 4 BIOSs and a UEFI. Nothing detected it other than an Ubuntu live OS while listing the drives/devices with said program mentioned above. That's what leads me to think that I screwed up in formatting.

Theory two: I'm forced to use E2B to meet my multiboot needs, which involves a few specific things to switch between payloads when in UEFI mode. This involves booting through BIOS, reverting the USB to BIOS mode, then choosing the new payload and converting the drive back to UEFI mode. I can do this with a QEMU emulator, so I have a simple .exe for portability's sake that I use to switch things in a hurry.

Right before I started installing Arch, I was changing the drive into the Arch UEFI mode. After it finished, I clicked to safely remove the drive and as soon as I saw the popup I removed it. Apparently it was still in use (stupid Winderp$), but I had already removed the drive before I realized what I did wrong. I don't really think this would cause the issue, especially considering that it booted right after I did this, but still the more info the better.

So I can't view it as a drive in Gparted, fdisk, lsblk, etc can't find it, and /dev/sdd (the next letter in order, thus the one it would be) doesn't exist. lsusb probably sees it as a "Linux Foundation 2.0 root hub" but I don't know how to tell if this is accurate or not. Programs like TestDisk, PhotoRec, Clonezilla, or anything of the sort don't see the device, so I can't just reformat and get it over with.

I can run whatever commands you want me to run, but as I don't have a working Linux partition as of current, it'll be off of a live USB unless otherwise necessary. I can always throw together a quick Ubuntu install if it's really needed.

I'm hoping that I don't lose my data and that I can restore at least most of it, but that's not necessary. If I HAVE to format it to get my USB back to a working format, then that's fine with me. I'd prefer to expend all of our resources on saving my data before we have to reformat, I have some things here I don't have anywhere else (stupid, I know. I keep backups regularly of my standard data, never considered this).

Using Winderp$ again, waiting for some help to come in as I'm out of options until I get suggestions. Noticed that system time is wrong, but I can't say for sure if this is relevant or not. Neither of my two theories seem plausible, as it's pretty hard to screw up typing parted /dev/sda/... While I'm in that session of parted, I'm fairly certain I can't even access /sdc/, so I fail to see how it could be user error, though it always is.


First of all, i wouldn't put much faith in recovering data from that drive.

Second, run dmesg | tail -n 20, before and after you plug your USB drive. If there's no kernel message, your drive is, most probably, completely dead. If you kernel detects the USB drive but can not assign a block device (/dev/sdX) to it, it's a firmware issue (you can try recover it using URescue). In both cases, you can send it to Corsair for RMA.

This is how dmesg reports a plugged USB device:

[433011.248119] usb 2-1.2: new high-speed USB device number 10 using ehci-pci
[433011.334351] usb 2-1.2: New USB device found, idVendor=0781, idProduct=5583
[433011.334359] usb 2-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[433011.334363] usb 2-1.2: Product: Ultra Fit
[433011.334367] usb 2-1.2: Manufacturer: SanDisk
[433011.334370] usb 2-1.2: SerialNumber: 4C5350122032812026
[433011.337486] usb-storage 2-1.2:1.0: USB Mass Storage device detected
[433011.338327] scsi host18: usb-storage 2-1.2:1.0
[433012.341971] scsi 18:0:0:0: Direct-Access     SanDisk  Ultra Fit        1.00 PQ: 0 ANSI: 6
[433012.343395] sd 18:0:0:0: [sdc] 60751872 512-byte logical blocks: (31.1 GB/28.9 GiB)
[433012.344718] sd 18:0:0:0: [sdc] Write Protect is off
[433012.344724] sd 18:0:0:0: [sdc] Mode Sense: 43 00 00 00
[433012.344990] sd 18:0:0:0: Attached scsi generic sg1 type 0
[433012.346597] sd 18:0:0:0: [sdc] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[433012.377606]  sdc: sdc1 sdc2 sdc3
[433012.381726] sd 18:0:0:0: [sdc] Attached SCSI removable disk
| improve this answer | |
  • Thank you for your help. As I mentioned above, Linux can see the drive, it just doesn't think that it's a drive. It sees it as "XXXXXXXX U168CONTROLLER" so as long as I can get a block device labeled to it, something like Photorec or testdisk should be able to get my data back (in theory at least). I ran this code on a different PC from yesterday, but it should work all the same as we're doing before and after here as well. pastebin.com/sUB7RRhs – Bugattikid2012 Sep 27 '15 at 17:29
  • @Bugattikid2012 It seems like a known issue for some Corsair drives (mainly 32GB GTR). There's a firmware update here: forum.corsair.com/v3/showthread.php?t=91444 – petry Sep 27 '15 at 18:49
  • Tried to go to their website and look for similar software, but they don't have any drivers on the website. Running the .exe says "URescue does not support this device.Please contact the manufacturer." Word for word, including the lack of a space there. Is there any chance it's finding the wrong drive or something by mistake? I've got a 64 GiB survivor drive, this should be working. Just read it again, this is meant for upgrading firmware from existing firmware, so it wont' work when it can't recignise the device to begin with. What else could fix this? – Bugattikid2012 Sep 27 '15 at 19:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.