1

I had an issue where sometimes the computer would hang at startup, during POST, with either a code 67 or 99 on the motherboard's debug LED (Asrock Z77 extreme4). If it was the former (code 67), the screen would not display anything, while the latter would display some info on the UEFI splash screen until the code 99 hang. Resetting the PC (sometimes two or three times were necessary) would get it to boot properly. The hangs always occurred the first couple of times after leaving the computer off (shut down) for a while, usually during reboots, and never after leaving the computer switched off at the power supply for a while; also never after resuming from standby mode (S3). The hangs occurred regardless of whether or not hard drives/SSDs or USB devices were attached.

I suspected a faulty power supply, so I replaced the Corsair RM650W with an EVGA 650W PSU. Same problem.

I then suspected a faulty motherboard, so I replaced the motherboard, CPU and RAM. The new motherboard is an Asus X99 Deluxe. Using the original (Corsair) PSU, I get intermittent hangs (though less frequent than before), with the same code 67 displayed on the debug LED, always fixed by a hard reset as before.

I am now suspicious of the graphics card, which is an Asus GTX 970. Once, this morning, I booted up the PC and it successfully went through POST, but with visual artifacts apparent on the top half of the screen until I rebooted.

However, the code 67 hang occurred on the previous motherboard regardless of whether or not the graphics card was attached. I don't have another graphics card handy and the newer motherboard doesn't have integrated graphics.

Does a graphics card problem sound likely, or is there another possibility which I have missed?

  • You mention in another comment that you have solved this issue, You should post it as an answer and accept it. – Burgi May 14 '16 at 15:43
  • From the problem has ceased to exist, it does not follow that the problem is solved. – felamaslen May 15 '16 at 18:22
2

To answer the question in minimum words, you are seeing a problem which I and others have experienced and which has not yet been solved either by us or by ASUS. My personal opinion is that there's a basic design flaw, but I no way to back that up other than by summarizing "my situation" as described below.

I have the original X99-Deluxe and I have talked with 8 or 9 others with it or the 3.1 board which you have. I'm on my 3rd one in 16 months (make that 13.5 as ASUS tech support kept me "motherboardless" for well over 2 months) and after the latest new problems, I'm giving up and throwing in the towel.

That being said I don't get the hang on the 9C code sometimes: I get it EVERY time I boot the box.

It has happened with 2 of the 3 motherboards (the first replacement arrived DOA, and ASUS would not cross-ship), AND:

a) it has happened with 3 different power supplies (currently an EVGA 1000G);

b) it has happened with ALL boards removed (including video - running remotely via tcp/ip);

c) it has happened with 5 different video boards;

d) the same thing has happened with the factory default settings and it has happened with them "tweaked" to my satisfaction (I don't overlock);

e) finally, it has happened with at least 4 (5?) different BIOSs installed in the motherboard.

The above being said there's one other annoying glitch with this motherboard which may be a part of the problem, but it's one which will be pretty much invisible if you run widows. If I put the machine in text mode (75 lines by 32 cols - VERY useful for looking at some large seets of tabular data), then with every video board I've tried there is a quick flash of a code on the LED display with every linefeed (or carriage return) which prints to the screen. It goes by too fast to read, but the result is that scrolling slows down drastically, and consequently it can take several minutes for a long text file to print which prints to the screen in 5-10 seconds on every other box I have here.

I have mentioned the delay in the "bus initialization" to the Asus service people with whom I've spoken, and I have variously been told "you have a bad board installed in one of the slots" (that was even with all boards removed), "it sounds like a CPU issue" (although the same CPU works flawlessly in another machine), "you don't understand how to time the scrolling to the screen" (duh), and my personal favorite, "that's impossible."

FWIW, my luck with ASUS support has been so bad and includes unkept promises and missed shipping dates (I last contacted them in 12/2015 and 1/2016 - it is now 5/2016 and they STILL haven't contacted me back as promised). Consequently I won't even bother to try again.

I finally decided to cut my losses and buy a more dependable board when this motherboard started giving random bus error messages none of which was repeatable and each and every one of which caused full system hangs of from 5 to 40+ seconds.

My Tech Background: S/W and H/W geek (and systems architect) who has been building systems both at the office (large multinational corporation with deep pockets) as well as for personal, family, and friends' use since at least the early 1980's) And since I still build a dozen or so systems per year, I'll have to avoid X99 Asus boards in the future.)

  • I actually stopped getting any problems with it when I sent the GTX 970 for a "repair". They said they couldn't find a fault with it, but lo and behold it caused me no problems when I reinstalled it after they sent it back to me, so they must have done something. I also don't have any problems with this board using a GTX 980 Ti which I since upgraded to. – felamaslen May 10 '16 at 13:16
  • FWIW not long after posted my response (above) the motherboard (ASUS X99-Deluxe) died and took the CPU with it. (third such MB to die, 2nd one to take the CPU with it. Will not buy another). I replaced it with an MSI X99A Xpower AC, and everything else (case, PS, cards, cables, drives, monitor, mouse, etc. ad nauseam) is the same. The problem has gone completely away. I'll chalk my problem up to what I think was a bios issue. – Airedad May 30 '16 at 18:08
  • Similar problem, but with ASUS Z99-based motherboards. I've built many at my workplace, but two of them have this issue: no POST on cold boot. I have to power cycle them a few times and then they magically boot up. No POST code LCD on the models we have, so I don't know if they're hanging at a specific phase of booting up. Still, no screen at all. Using EVGA NVIDIA GTX 650 video cards, or just using no card and the built-in Intel video, same issue. Affects two systems out of may be a dozen. Yet they've been working fine since 2013, and users leave them on all the time. – John Suit Oct 13 '16 at 18:06
1

It used to be common knowledge and the problem has gotten far better over the years so people don't always think of it these days. Sometimes the act of removing the board and reseating it into its slot will fix some problems with "hang on boot" (or related issues). So it's possible that they really didn't do anything to fix the board beyond cleaning the card.

Case in point: I have an ultra-SCSI tape drive which I use for backups. About 2 months ago the system started hanging on reboot. When I finally pulled the SCSI board from the MB, I discovered that one of its contacts looked "dirty". So I cleaned (carefully) with a vinyl eraser and put it back into the machine. The problem was instantly solved.

  • Once you've identified a piece of hardware as a possible culprit, it is indeed a good (and cheap) idea to take a pencil erasure to the contacts to clean them, and then try re-seating the board and re-testing. – music2myear Feb 1 '17 at 16:55

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.