I uninstalled the Calculator app like this in PowerShell:

Get-AppxPackage *windowscalculator* | Remove-AppxPackage

How do I reinstall it?

up vote 20 down vote accepted

This one worked for me, just combined the commands from the other answers found here. Note: you have to use the -Allusers option with the Get-AppxPackage command since it is not installed anymore under your current user account:

Get-AppxPackage -allusers *windowscalculator* | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}
  • Here's another variant of this answer: get-appxpackage -allusers windowscalc |foreach {$_.InstallLocation+"\AppxManifest.xml"} |add-appxpackage -disabledevelopmentmode -register – Will Bickford Apr 19 at 2:42
  • Make sure to run the PowerShell as an administrator. Otherwise, it might not work. – Sathish Apr 19 at 14:14

Here is the MS Store link to the Windows Calculator.

Note: This will only work if you have the Windows Store app installed.

To reinstall an individual app use PowerShell and run it in admin mode. Screenshots:

http://imgur.com/a/mAKZe

Next get the full name of all apps, e.g. Windows Calculator paste this snippet in PowerShell and hit enter:

get-appxpackage -allusers | Select Name, PackageFullName

For single full name of the desired app name, e.g. Windows Calculator paste this snippet in PowerShell and hit enter:

Get-AppxPackage *windowscalculator*

Now copy the full name that looks like this: Microsoft.WindowsCalculator_10.1601.49020.0_x64__8wekyb3d8bbwe

Finally the we are going to install that app again with this snippet:

Add-AppxPackage -register "C:\Program Files\WindowsApps\Microsoft.WindowsAlarms_10.1603.12020.0_ x64__8wekyb3d8bbwe\appxmanifest.xml" -DisableDevelopmentMode

Re-installed app is available without restart of the PC!

N.b: To remove individual apps use this code: Get-AppxPackage *alarms* | Remove-AppxPackage

A list of all apps when removing is (Here)

  • Are you reinstalling WindowsAlarms or WindowsCalculator? I get Add-AppxPackage : Cannot find path 'C:\Program Files\WindowsApps\Microsoft.WindowsCalculator_10.1712.3351.0_x64__8wekyb3d8bbwe\appxmanifest.xml' because it does not exist. – ajeh Apr 12 at 20:03

Try Get-AppxPackage *windowscalculator* | Add-AppxPackage

or the following to install all default apps: Get-AppxPackage -AllUsers| Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

  • Thanks. I already tried Add-AppxPackage but there is no success or fail message - nothing happens. Unless I have to restart windows, which I haven't tried since I have a lot open/running. I know it's possible to reinstall everything, but there should surely be a command to install individual core apps? – John Valai Sep 27 '15 at 18:17
  • The first command does nothing, the second one wants installation media. – ajeh Apr 12 at 20:00
  • @ajeh It's important to run the commands in PowerShell, as an admin (right click and "Run as Administrator"). Not sure why it would ask for installation media, but in the worst case, you can always flash a USB with with Windows 10: microsoft.com/en-gb/software-download/windows10 – Arty2 Apr 13 at 8:02

Just install it from the Windows Store if you have that installed. Windows Calculator | https://www.microsoft.com/store/apps/9wzdncrfhvn5

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.