11

I have Windows 10 and when right clicking on .ISO files there is usually "Mount" as an option.

But when I installed Nero Burning Room, "Mount" disappeared from the context menu.

How can I add it back?

25

This could be because Nero became the default program for opening .iso files, so you'll need to undo that.

Try right-clicking on any ISO file, and then in the Open with... option, select Choose default program. There you'll have to choose "Windows Explorer".

Check if the Mount option is back, and that's it!

  • 2
    An alternate option is to restore the default file association for .ISO files using CMD.EXE assoc utility (note: CMD builtin, not directly usable in Powershell). The default file type in the registry is Windows.IsoFile, so the command would be assoc .iso=Windows.IsoFile. – CBHacking Sep 28 '15 at 7:28
  • Yeah, that could also be a way, but I always prefer to use the "native" tools, instead of messing up with registry and that stuff, if possible (because it's easier, and there's less risk of messing up the system). Good point, though. – Hewbot Sep 28 '15 at 13:18
  • an alternate option is to uninstal this trash player VLC – Jaxx0rr Dec 30 '18 at 5:44
  • Now any attempt to open ISO file lead to infinite explorer recursion... – Pavel Mayorov Oct 24 '20 at 12:19
1

As an alternate of adding Mount back to the context menu...

If you like having the default application for opening the .iso file to be something other than Explorer (i.e. Nero) then leave it as default.

When you want to "Mount" the .iso... Right-click on any ISO file, then in the Open with... option, select Windows Explorer.

I like this option because the file still opens with my favorite burner app, but still allows me to mount it in Windows Explorer (which I use less often).

-2

I got 2 options if anyone is still having problems.

  1. With your ISO file left click and the ISO program should open, click "Continue to Try..." then the full program should open, after that you can highlight all files in there and drag to desktop or any file as you wish and continue to use the files on your desktop.

  2. Goto drive "E:" or whatever you call yours and right click, hover over the UltraISO option and click "Mount", a folder should open and search for your ISO file you wish to import and click it. After that everything should go the same like the ISO did before.

(NOTE: These will not fix the "Mount" problems but they are only ways to use ISO differently yet almost the same way)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.