1

Background

I am trying to install a few applications like tftpd-hpa, samba, and apache2 however i can't seem to do this. I've tried looking around on google for answers to no avail. I have had some luck installing dnsmasq and ssh and I'm using those fine. But when I try install other applications I get a bunch of error messages.

Package samba is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'samba' has no installation candidate

Apache2 seems to have a slightly different issue:

The following packages have unmet dependencies:


apache2 : Depends: apache2-bin (= 2.4.10-10+deb8u1) but it is not going to be installed
           Depends: apache2-utils (>= 2.4) but it is not going to be installed
           Recommends: ssl-cert but it is not installable
E: Unable to correct problems, you have held broken packages.

When installing tftpd-hpa

E: Unable to locate package tftpd-hpa

Attempted:

I have attempted to change my mirror in /etc/apt/sources.list and using apt-get afterwards. This didn't work. I am in NZ so I am using "ftp.nz.debian.org/debian" as the source. And in addition I installed it from a CD and when I installed dnsmasq and ssh they asked me to put the cd back in. So I don't know if this is the issue.

Potential Issue:

So I think it has to do with my http://ftp.nz.debian.org mirror. I have changed my mirror to Australia which is just a few hours away and manage to get all the packages. I have also tried using all the other nz mirrors to no avail. Guess my island is just dead.

2
  • Did apt-get update work as expected?
    – AFH
    Sep 28 '15 at 1:12
  • Yes and no. It worked and errored out on my ftp.nz.debian.org entry Sep 28 '15 at 1:18
2

First off, remove the CD lines from the top of /etc/apt/sources.list. Then set your mirror to httpredir.debian.org in the same file and run apt-get update. Then retry the apt-get install command.

This will use the Debian Mirror Redirector at http://httpredir.debian.org/, that way it (should) always point you to a working mirror.

As for nz.debian not working, if you look at http://ftp.nz.debian.org/debian/ there are two files at the top right now:

[SND] Archive-Update-in-Progress-mirror.aarnet.edu.au 24-Sep-2015 13:52 0 [SND] Archive-Update-in-Progress-mirror.waia.asn.au 24-Sep-2015 16:00 6

Which means the mirror is syncing from the West Island right now.

ftp.nz.debian.org is an alias for ftp.citylink.co.nz which would be why trying the "other NZ mirrors" woudn't have helped.

2
  • 1
    thanks man. did not know about the two archive mirrors. Sep 28 '15 at 2:15
  • Hopefully it's all working now. Feel free to post more questions or get in touch if you have further issues. Sep 28 '15 at 2:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.