This question deals with finding applications in general but not portable ones: Cortana Search is not finding applications on Windows 10

I have a portable application located but not installed at C:\sdk\cmder\Cmder.exe. I also have a shortcut located at: C:\Users\twing\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\cmder.

Finding normal, installed applications, work fine, but I can't find cmder, if I search for it, and it works the same for other portable apps.

Re-indexing doesn't affect the problem at all. I even added a new indexed location C:\sdk\shortcuts and added cmder and an internet shortcut, but it doesn't work either.

I also tried adding C:\sdk itself where the ´.exe`s are located, but it makes no difference.

How do I fix this?

3 Answers 3


Portable Apps, or really any Programs at all can be indexed in one of two ways.

  1. By being located on the System Path as a *.exe
  2. Being within the Registry. There are several ways to accomplish this, but the easiest of these is to register the Application within App Paths

An example of this being (in PowerShell):

New-Item -Path HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\myapplication.exe -Value C:\blah\myapplication.exe

It works. The only issue is it takes literally all day for the rebuilt index to start to show up in the start menu even on a fresh clean install of windows 10.

After searching for this yesterday and today here's how I eventually found my portable app in my start bar.

Keep in mind I just "reset" win 10 early this morning so this is a "fresh" install.

I searched for this same topic this morning, found this post, downloaded a portable and installer version of this app.

Around 9:00am Installed the installer version thinking cortana was only finding things in the registry not just MUI entries. Copied the start menu shortcuts the installer version created. Directly uninstalled the installer version and after it was uninstalled I put the shortcuts back in C:\ProgramData\Microsoft\Windows\Start Menu\Programs and changed their paths to point at my portable version of the same app. I made sure the shortcuts were indexable under Indexing Options and rebuilt the index. Fiddled with ownership and sharing options for about 30 minutes, anything I could think of that would allow cortana to get a "better view" of my app. (In hindsight i doubt all of this is necessary, I think cortana just sucks right now and it literally takes 8 hours for it to index a hand full of shortcuts)

At 5:30pm Out of habit I slammed the windows key and typed in the name of my app expecting it to show forgetting all about the fact that cortana doesn't index portable apps and low and behold the icon appeared in the corner of my eye and I launched it, from pure muscle memory. I checked to make sure that I was actually launching the portable version of the app and sure enough here it is.

Note: Until Cortana is fixed properly, might I suggest Everything Search Engine for your desktop? It will index terrabytes of data in a matter of seconds. It doesn't index the content of the files of course, but it will supplement your portable app searching needs and outshine anything windows has or will come up with in the near future. http://www.voidtools.com/

Image link proof. superuser.com doesn't feel I'm worthy enough to post images yet. https://onedrive.live.com/redir?resid=4101341642620E2A!4025&authkey=!AEIaKWYQs5wSfaM

  • Please test with a portable which doesn't have an installer available and make the shortcut yourself... MobaXTerm could leave registry entries or other things even after the install that does something of value... The duration of rebuilting the index depends on how many files there are, how fast the CPU and the SSD/HDD is... For me, it has been saying "Indexing Complete" for a few days now.
    – Centril
    Oct 6, 2015 at 12:34
  • My example does site a portable. It can be downloaded from this url. The portable version is the link on the left. mobaxterm.mobatek.net/download-home-edition.html Jan 27, 2016 at 15:53

How many apps do you have linked? According to this forum:


apparently if you surpass a certain limit, apps will not show in search. Also, not sure if you've tried it, but there's another solution to the search issue listed here:


  • I installed at least: RollerCoaster Tycoon, Windows SDK and NoMachine after I rebuilt the index... if it was hitting the limit, these apps would not show up in search, but they do - all of them, so this can't be the issue.
    – Centril
    Oct 6, 2015 at 12:31
  • True, must be something else, likely a bug. As you can see with all the other search problems they're having, it might take a while to sort out their bugs.
    – xCare
    Oct 6, 2015 at 14:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .