0

I want to be able to access my pc with VNC from a remote location. Because my pc is behind a router (TP-Link WR841N) with NAT enabled, I've forwarded the the required port (5900) to my pc's local IP-adress.

However if I try to connect with the VNC server from outside my local network, it will time out. The port appears closed as well via services like http://www.canyouseeme.org

Things I've tried:

  • I've added allow-rules to both the windows firewall (which is disabled) and comodo antivirus (which is enabled), but this doesn't seem to help.
  • I've also tried setting it all up for a slightly different port (5901)
  • Finally I've tried this all with both TightVNC and RealVNC.

Other things of note:

  • I've tried enabling VPN as well and have run into the same issue, but I haven't quite tested that as extensively as with VNC.
  • I have another pc running Ubuntu in the same local network which is accessible with VNC, I've forwarded port 5904 on my router to 5900 to that pc's local IP (this shouldn't interfere right?).

Does anyone know something else I can try or where I maybe messed up?

  • So VNC port is working fine within your local network but not externally? Sounds like the router isn't forwarding the port. One thing you could try is set the PC IP as the DMZ on your router. Which will open your PC to the WAN. This way you could do a quick test to see whether the router is forwarding the traffic or not. – lbanz Sep 28 '15 at 13:16
  • Thanks for the suggestion. If I enable DMZ it works. But I'm using the same forwarding settings (aside from the actual port numbers) for my Ubuntu server which does accept external VNC connections, so I don't understand what I'm doing wrong with the forwarding. – Witts Sep 28 '15 at 13:28
  • Are you sure your router is not blocking ports? Also consider that some ISP's block incoming syn traffic (they don't want people running services from their home internet connection for obvious reasons). – dc5553 Sep 28 '15 at 13:30
  • Would you mind posting a picture of your router's NAT settings? – Hewbot Sep 28 '15 at 13:31
  • 1
    Have you noticed that you're redirecting 5901 to 5901, instead of 00? Is it intentional? – Hewbot Sep 28 '15 at 13:56
-1

Following a suggestion by Ibanz, the problem is resolved by enabling and disabling DMZ.

Things seem to be working permanently now after having DMZ enabled. I've since already disabled it and also rebooted the router to make sure it wasn't secretly still working that way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.