11

Since Windows 8, but specifically for Windows 10, there is a new logon screen that requires a key press to trigger an animation to bring up the input screen for the password. The animation itself takes a few seconds to enable as well.

This is jarring coming from Windows 7, where you could just enter a password at the terminal and log in. Now you need to press a key, wait, enter password.

Are there any known work around to disable the first screen and/or remove the animation.

3

Here's the answer taken from www.ghacks.net:

Local Security Policy

  1. Tap on the Windows-key or press the Start button, type Local Security Policy in the search box and open the item of the same name.
  2. Select Software Restriction Policies > Additional Rules.
  3. If you don't see the menu, select Action > New Software Restriction Policies to create it.
  4. Right-click on the right pane and select New Path Rule.
  5. Under Path, paste C:\Windows\SystemApps\Microsoft.LockApp_cw5n1h2txyewy
  6. Make sure the security level is set to Disallowed.
  7. Click OK.
  • Verified and my answer still works for 10 Pro... – cybermonkey Jul 6 '17 at 18:27
8

Yes, you can disable it (via Group Policy Editor):

  1. Type WinKey + R, enter gpedit.msc & press Enter:

enter image description here

This invokes the Microsoft Management Console, with the Group Policy snap-in.

  1. Navigate to Computer Configuration > Administrative Templates > Control Panel > Personalization:

enter image description here

  1. Navigate to Do not display Lock Screen, right-click and go to Properties:

enter image description here

  1. Set the value to Enabled:

enter image description here

That's all there is to it.

Group Policy is a great way of getting 'under the bonnet' of Windows, and allows for a more refined Windows experience.

  • This should be the accepted answer – Enrico Jul 6 '17 at 15:24
1

For Windows 10 Home edition users the group policy editor (detailed in the answers given already) isn't available. Enabling the group policy editor manually and then following the given instructions also doesn't work.

To disable the lock screen (i.e. show the login prompt directly when recovering from sleep/on reboot) I used the directions given at:

https://www.ricksdailytips.com/disable-lock-screen-in-windows-10/

This works for now; although I cannot confirm if it remains that way after updating windows.

The instructions:

1 – Press the Windows+R key combination to open a “Run” box.

2 – Type regedit into the Run box, then press the Enter key to open the Registry Editor utility. Note: Click Yes if the “User Account Control” box pops up.)

3 – Create a backup of the Registry by clicking File>Export, then giving the backup file a name and saving it to the Desktop. Note: Be sure to select All for the “Export range”.

4 – Navigate to this Registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows

5 – Now, check to see if there is a Registry key called Personalization under the Windows key. If not, create one by right-clicking in the right-hand pane, clicking New>Key, and then renaming the new key to the name Personalization.

6 – Click on the Personalization key to select it.

7 – Right-click in the right-hand pane and select New>DWORD (32-bit) Value. Note: Select DWORD (32-bit) Value even if your PC is running the 64bit version of Windows 10.

8 – Name the new value NoLockScreen.

9 – Double-click on NoLockScreen, enter the number 1 in the Value data field, then click OK.

10 – Exit the Registry Editor by clicking File>Exit.

11 – Reboot your PC to cause the Registry change take effect.

New contributor
Bram is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.