2

I have the following problem. When I start up Outlook 2007, I get an error box saying that "The file D:\Documents and Settings\my_username\Local Settings\Application Data\Microsoft\Outlook\outlook.ost cannot be opened", where my_username is my email username.

However, there is no D:\ on my computer. My old computer had a partitioned drive with a C:\ and D:\ and I guess IT set it up to save the Outlook profile on the latter. When they migrated me to the new computer, they did not change this.

Now Outlook is looking for the OST file in a location that does not exist.

The big problem here is that all of the settings you would typically use in Outlook to manage the location of OST files will not work if they cannot find the current one.

For example, most of the info I found online about OST file problems recommended forcing Outlook to recreate the file, as described in this thread:

Recreating your .OST file should fix this issue.

Open Outlook>File>Data File Management>Data Files

Remove file name outlook.ost

Restart Outlook.

However, when I look at the list of Data files, I see that the default one doesn't seem to have a location:

enter image description here

And if I go into the settings for that profile and try to edit the Offline Folder File Settings, it just tells me again that it can't find my OST file.

enter image description here

So, my question, which I've found no info on elsewhere, is not where does Outlook store the OST files, but where does it store the location of the OST files, i.e. what is making Outlook look in D:..., and can I manually change that pointer outside of Outlook somehow? I thought maybe there would be a registry key or something that had that string stored but so far no luck with registry searches.

Thanks.

  • Open Account Settings then click on the .ost file and hit Remove. So in your screenshot you would just remove the entry you have selected. – Ramhound Sep 28 '15 at 18:16
  • It won't let me remove the current one because it considers it the default. – SSilk Sep 28 '15 at 18:20
  • ... and if I try to add another one, I am only given the option to add a PST file. I tried this, but then it asked me if I was sure I wanted to move all my data off the Exchange server which did not sound like something I wanted to do. – SSilk Sep 28 '15 at 18:21
  • So setup a new exchange account. Because currently you don't have one setup. If you don't know how to do that ask your IT support team to help you. But the solution is to remove the invalid file. – Ramhound Sep 28 '15 at 18:57
3

OK, I know I just posted this question, but that was at the end of several hours of frustration and it turns out that the one other thing I was going to try actually fixed this issue.

Because Outlook was hellbent on looking for the OST file in D:..., I put in a USB drive and renamed it D:\, then added the path that Outlook was looking for. When I restarted Outlook, I saw an OST file get created in that folder.

That allowed me to access the Data File settings that I was previously blocked from. I then disabled Offline Use because Outlook won't let you change the location of an OST file currently in use. Then I exited and reopened that dialog and found that Outlook had automatically switched it to C:. Seems to be working now.

So, if you're having this problem where Outlook is looking for an OST file in a location that does not exist, do the following:

  1. Set up a USB drive mapped to the drive letter Outlook is searching on. You can do this in Windows Disk Management. I'll assume you can figure that out with some Googling or searching on this site.

  2. On that drive, create the exact path Outlook is looking for, in my case "D:\Documents and Settings\my_username\Local Settings\Application Data\Microsoft\Outlook\"

  3. Open Outlook. You should see an OST file appear in the folder you just created.

  4. In Outlook, go File->Data File Management->Data Files, select the relevant Mailbox (there was only one for me), and click Settings. enter image description here

  5. Click Advanced, then Offline Folder File Settings. If you did not create the dummy OST path in step 1, at this point Outlook will complain again about not being able to find your OST file...

enter image description here

  1. ... but since you did, you should now see a small settings dialog box with the incorrect pathname listed (D:... for me):

enter image description here

  1. Click Disable Offline Use. You will get a confirmation dialog, hit yes.

  2. After doing that, I exited back out to the main Account Setting dialog (which opened in Step 4). When I went back into the Offline Folder File Settings box, Outlook had already filled it in with the correct path (C:...), and appeared to have re-enabled offline use (the "Disable Offline Use" button was available for clicking again rather than being greyed out).

  3. Test by removing the the USB decoy drive, and restarting Outlook. You should find it no longer complains about not being able to find the OST file.

0

Ref: http://www.msoutlook.info/question/591

It should be possible to create a new pst/ost file in this situation, then set it as the default one.

After that the faulty one should be free to close or delete.

Untested

  • In my situation, I can create a PST file but then when I try to set Outlook to use it, I get a warning that it is going to move all my data off the IMAP server, which I did not want to do. Maybe I could have done that, then deleted the old OST file location, created a new one and pointed back at that. But I'm not sure if that would have worked or would have left me with nothing on the IMAP server. – SSilk Sep 29 '15 at 20:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.