So basically, I'm trying to install rEFInd. I've gotten everything to go successfully besides this part:

Type bcdedit /set {bootmgr} path \EFI\refind\refind_x64.efi to set rEFInd as the default EFI boot program. Note that {bootmgr} is entered as such; that's not a notation for a variable. Also, change refind_x64.efi to refind_ia32.efi on systems with 32-bit EFIs. Such computers are rare, and most of them are tablets. Check your Windows bit depth to determine which binary you should use.

I get this:

The parameter is incorrect.

The exact line I enter is

bcdedit /set {bootmgr} path \EFI\refind\refind_x64.efi

I recall this working in earlier versions of Windows, but not here. What should I do?

Please note that EasyUEFI and VisualBCD are both screwing up. Here is a full output of my current BCD:

up vote 1 down vote accepted

You can create a separate boot entry in NVRAM for rEFInd and set it as default (first boot choice) if this is the desired result. This should be possible using your UEFI firmware functionality for setting/creating new UEFI boot entry.

If this is not possible using firmware functionality:

I just changed "ApplicationPath" for {bootmgr} object using Visual BCD Editor in Windows 10 - 10240.

You have to map EFI System partition(ESP) to drive Z: for example (use diskpart.exe or mountvol.exe) and later use search button when editing ApplicationPath element to select rEFInd executable on ESP - "\EFI\refind\refind_x64.efi".
("ApplicationDevice" should show Z: or else you will get application exception)

enter image description here

  • I opened up Visual BCD, and selected Windows Boot Manager under Loaders. From here, I tried double clicking ApplicationPath, entering the proper path, and clicking OK. However, the value field did not update. Using the search button and selecting the rEFInd .efi file that way didn't work either. – TheForgottenArchitect Sep 29 '15 at 16:41
  • 1. Map ESP to Z:. 2. Select {bootmgr} and edit its ApplicationPath. – snayob Sep 29 '15 at 16:48
  • That's what I did. I'll get you some screenshots, give me a second. – TheForgottenArchitect Sep 29 '15 at 16:50
  • Before: vgy.me/ZYh7J9.png – TheForgottenArchitect Sep 29 '15 at 16:51
  • Right before hitting "OK": vgy.me/A6s3e9.png – TheForgottenArchitect Sep 29 '15 at 16:52

In Windows 10 you have to quote {bootmgr}. The new line is

bcdedit /set '{bootmgr}' path \EFI\refind\refind_x64.efi
  • 1
    Or use CMD instead of PowerShell. – Martín Coll Dec 19 '16 at 1:36
  • 1
    @MartínColl You should post that as an answer, since that is THE answer. Quotes will fail in cmd.exe but are needed in Powershell. – Adam Plocher Jan 2 '17 at 13:31

If you're using PowerShell you need to quote as answered by @zauguin.

Another option would be to use CMD, which is the terminal that the rEFInd author used when writing the guide.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.