2

Related to How can I disable the 'Installing Apps' screen?

I recently set up a new domain, everything runs as it should but however certain Group Policy settings won't sync. One of these settings is Folder Redirection.

Other stuff for ADDC & Group Policy works, such as:

  • Signing onto domain computers with domain users
  • Domain network policies
  • Security policies (such as requiring Ctrl + Alt + Del to sign in)

I definitely have done the Group Policy Object properly as most Group Policy settings are synced onto domain clients.

I have set the Folder Redirection by User Configuration > Policies > Windows Settings > Folder Redirection

Each folder is located on a shared network drive that backs up automatically to cloud services. I've verified that users are in the Domain Users group.

enter image description here

enter image description here

Users are also able to fully access their allocated storage areas manually by browsing to the location on the network drive, so there's nothing wrong with the folder permissions. Forcing a Group Policy update via gpupdate.exe /force will not get this to work either.

What am I doing wrong?

All clients are on Windows 8.1 Professional & the server's running Windows Server 2012 R2 Datacenter.

The OU the GPO only applies to domain computers (which at the moment, there's only two and the naming structure isn't well-formed, but that's going to change):

enter image description here

  • Is your WIN-8K70... a server on your LAN? I'm just wondering if you are pointing the GPO to a mounted cloud folder (to immediately cause files to be synced to the cloud) and it's causing the redirection to fail... does your cloud storage have a client installed on the server that manages the backing up, or do your users connect directly to the cloud storage when they go to their folders? – Kinnectus Sep 29 '15 at 17:15
  • 3
    Have you linked this GPO to an OU containing the users (not computers) you want this to affect? Have you used GPresult to confirm the policy is actually applying to the user(s) successfully? – Ƭᴇcʜιᴇ007 Sep 29 '15 at 17:16
  • 1
    @BigChris Yes, it's on a LAN. The cloud storage has a client that automatically syncs any files created in its area. – AStopher Sep 29 '15 at 17:19
  • 1
    @Ƭᴇcʜιᴇ007 Only domain computers are in the OU. Would that explain why some settings in the GPO apply and not others? This is my first time doing domain networking like this, so please bear with me if there's something blindingly obvious that I've missed. – AStopher Sep 29 '15 at 17:20
  • 1
    @Ƭᴇcʜιᴇ007 Just tested it, it works! Not only that, but other stuff that didn't work before is now also working such as GPO software installation. Write an answer, and I'll accept it. – AStopher Sep 29 '15 at 17:29
2

This is a common gotcha for new GP admins: Say you make a GPO and link it to an OU. When you make changes in the GPO's "User Configuration" section those changes will only apply to the users in the OU it's linked to. If you make changes to the "Computer Configuration" section, those changes will only be applied to computers in the OU it's linked to.

What you've shown us here are User Configuration settings, so the GPO needs to be applied to a container (OU or otherwise) that contains the USERS you want this to apply to.

Similarly, if you're going to use Security Filtering in this case, you need to target user accounts to allow/deny access to, not (just) computer accounts.

Hope that helps. :)

  • Thanks :-). I did say that there was probably something blindingly obvious that I missed, and here we are! – AStopher Sep 29 '15 at 17:31
  • 2
    No problem. :) Next two general GP tips: 1) Never edit the Default Domain Policies, always make new, task-specific GPO's to apply settings that override the defaults. 2) Disable the User or Computer configuration section of any GPO that doesn't have any settings set in that section. So if you have a GPO that only has User Configuration changes, Disable the Computer Configuration section. This saves lots of log in/processing time later when you have lots of GPOs (see #1). :) – Ƭᴇcʜιᴇ007 Sep 29 '15 at 17:35

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.