4

I am really stumped with this one.

It seems that my laptop, while it has a USB in any of the ports, won't go past BIOS splash, no matter if I try to do a regular boot or try to use the "Novo" or OneKey rescue button it will just hang in the Lenovo Splash screen.

To start it is a Lenovo G500 laptop with one of those OneKey rescue buttons that lead you into boot selection (what device to boot from) or BIOS setup. Without the USB in it will go just fine and everything works. But I need to boot from my USB so that I can install Linux from it.

The steps I tried so far:

I disabled secure boot. It gets me stuck in an infinite boot cycle.

I tried every setting and every modification to BIOS (excluding flashing BIOS or clearing CMOS) to no avail, including:

Setting Legacy boot (instead of UEFI). Nothing.

Setting Legacy boot + usb boot enabled + Legacy usb support disabled, nothing.

It will boot into BIOS if I disable boot form USB. Making it impossible to boot from one, but that won't do because I need the USB to install the new OS.

The USB works fine, I tried it on another pc and It worked fine. Now I've installed Linux on this machine before, in fact I did it 3 times this year alone, and it has always gone without a hitch... It has been 2 days now, and I don't know what else to try.

  • What do you mean when you say you tried the USB in another machine? Did you actually try to boot the other machine from the USB, or did you just connect it and see if it was readable from the OS on that machine? A USB must be set up and formatted as a bootable device, just like a disc or a HDD must be in order for the machine to boot from it. If not, it will just be accessible as a data drive, not a bootable drive. – BBlake Sep 29 '15 at 19:37
  • I tried to boot form there, sorry for not being clear. It worked fine. – LocoKnight Sep 29 '15 at 19:41
1
  1. Enable UEFI boot to be default.

  2. Enable CSM (BIOS support).

  3. Put USB in USB 2.0 port (even if USB stick is 3.0).

Use device selection after firmware initialization and select "UEFI USB device" if present else select "USB device".

If disk is formatted using GPT style you should use only UEFI booting.

If disk is formatted using MBR style you should use only BIOS booting.

See also plop boot driver/manager - https://www.plop.at/ - can be useful if computer cannot boot from USB.

  • Sorry for not answering for so long, but I tried your steps. first when I switch to UEFI I get stuck in an endless boot loop. If I select Legacy support it just gets stuck at firmware initialization. And Plok doesn't seem to recognize the USB as bootable, even though it is fully bootable (tested it on another PC). – LocoKnight Oct 2 '15 at 19:02
0

Well, I installed linux using a bootable DVD.
Not sure why it didn't want to go past firmware with a bootable usb in but there you have it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.