14

Since I've upgraded from Windows 7 to Windows 10, the screensaver doesn't start anymore, and the screen never goes into standby when my gamepad is plugged (even idle) into the computer. "Allow this device to wake the computer" is unchecked in the gamepad's properties.

Disabling the gamepad from the Device Manager works as a workaround, but I would prefer a solution that doesn't involve disabling or unplugging.

11
  • Have you found the screensaver settings panel, and what does it say?
    – harrymc
    Oct 21, 2015 at 16:34
  • Does invoking the sceensaver manually work?
    – William
    Oct 22, 2015 at 15:25
  • @harrymc : yes, I've set the screensaver to 1 minute, and it doesn't ever start. However, when I click on "Preview" it starts and doesn't stop as long as I don't touch the mouse.
    – Cutter
    Oct 22, 2015 at 18:01
  • @William: yes, invoking the screensaver manually works, and the screensaver doesn't stop unless I touch the mouse. However, I've set Windows to put the monitor in standby when I press the computer case's power button, and when I press it, the screen turns black but turns back on after one second, as if something triggered it immediately out of standby.
    – Cutter
    Oct 22, 2015 at 18:11
  • It wouldn't hurt to post a screenshot of the screensaver settings panel as described above. Please also run powercfg -energy and post the report - this will take 60 seconds and the result is in the file energy-report.html in the current folder (not all the signaled "errors" need fixing).
    – harrymc
    Oct 22, 2015 at 18:40

7 Answers 7

2

Updating Windows 10 to version 1511 (build 10586.3) solved the problem.

3
  • 5
    Maybe it did once, but the problem is definitely back. I've had it 1709 and 1803.
    – Zan Lynx
    Jun 18, 2018 at 18:14
  • Bob Phrapples had an answer on the bottom that worked for me, and it will probably work for others too, if you have GeForce Experience installed.
    – diynevala
    Jul 7, 2020 at 18:57
  • Un-accepting this because I get the issue again after updating Windows 10 to version 2004.
    – Cutter
    Dec 8, 2020 at 17:21
2

This is old but still an issue, so if you come here with this issue and the stuff above doesn't help, I fixed my issue by turning off GeForce Experience In-game Overlay. For some reason this is the problem.

1
  • I would like to upvote more. This is confirmed and most probably the right answer.
    – diynevala
    Jul 7, 2020 at 18:52
2

Update: It appears the information below, while helpful, do not actually resolve the issue. The best resolution at this time, at least for me, is still just to unplug any USB controller when not in use.

My guess is the analog drift, while not relayed in controller movement, is still recognized by the OS as activity. However, the steps below are still helpful for resolving other issues related to drift, so I will leave them here.


I recently dug out one of my old game controllers (Saitek P880) and started experiencing this problem. It took a while just to get to this level of troubleshooting, so I appreciate all the hard work everyone did to get us to this point.

In my case, the issue was caused by an erratic analog axis sensor, causing the analog axis to drift (actually, more like swap between two different values rapidly). Sometimes rebooting or disconnecting the controller will cause the issue to temporarily go away, but eventually the drift will return. The Windows USB Game Controllers control panel does not have a built-in capability to adjust dead zones.

However, at least in the case of Saitek, their website still includes 32-bit and 64-bit drivers that work in Windows 10, including for my P880. Once the drivers are installed (reboot required), the control panel is updated with a much better representation of the buttons and functions, as well as a new tab to manually set the deadzone.

Bear in mind the files must be retrieved using the FTP protocol, and since this functionality is slowly being removed from the latest browsers, you may need to consider using an alternative utility (such as WinSCP) to retrieve them.

Here are two images showing the updated control panel with deadzone modified. You can right click any of the axes controls and uncheck "Link Deadzones" to more granularly control the deadzone range.

Images

Test tab Deadzones tab

1

The Nvidia Geforce Experience overlay may also be causing the problem. Read https://details-of-note.blogspot.com/2020/12/nvidia-3-year-old-bug.html

Disabling the overlay will allow it to sleep. Or hope Nvidia fixes this.

1
  • I don't have it installed.
    – Cutter
    Dec 8, 2020 at 17:20
0

A couple posts on this page suggest the following:

Windows 10 don't turn off monitor neither screen saver turns on

  1. In Power Settings, enable "When sharing media: Allow the computer to sleep."

  2. In Device Manager, disable "HID-compliant game controller" and "Virtual XInput device" under "Human Interface Devices."

1
  • 1. I don't have that setting. Maybe because I have uninstalled Windows Media Player. 2. Disabling "HID-compliant game controller" disables my gamepad. I'm looking for a solution that avoids that. I don't have a "Virtual XInput device".
    – Cutter
    Sep 29, 2015 at 23:22
0

Sometimes the Windows 10 upgrade process leaves behind installed drivers that would have been better replaced with the ones that come with Windows 10. I would suggest deleting in Device Manager the device for the gamepad, then also that of its USB hub, then reboot Windows to reinstall them.

Comments on your Energy report, relating mostly to sleep problems but which might relate :

  • It is strange that the sleep-state S3 is disabled, when Hibernate (S4) is allowed by your hardware. Normally I would advice to update the BIOS. But as the last firmware for your Gigabyte motherboard is a beta version from 2011, this hardware seems to be somewhat abandoned by Gigabyte.
  • The energy report says your monitor driver is missing or misconfigured. The last HP ZR24w LCD Monitor Driver from HP dates from 2013, and is verified for Windows 7 (64-bit), so should work for Windows 10. But check first if yours is newer.
  • You might try to enable USB Selective Suspend, to allow Windows to put USB devices separately to sleep.
  • Block Media streaming in Network and Sharing Center / Advanced sharing settings.
  • Final lame advice : Turn off the gamepad when you leave the computer.

If this does not help, please post more details about the gamepad.

Sometimes the Windows 10 upgrade process leaves issues and repeating it with a downloaded full installation media may solve the issue, as described in this answer.

If everything fails and the problem is unsupportable, you can always downgrade back to the previous Windows version, as described in this answer.

8
  • I've uninstalled the drivers for this device and its USB hub, but it seems that Windows reinstalled them after reboot, and the problem persists.
    – Cutter
    Oct 25, 2015 at 21:21
  • Please post full details about the gamepad and your BIOS.
    – harrymc
    Oct 25, 2015 at 21:23
  • The "gamepad" is actually a Madrics adapter for a Playstation gamepad. When plugged, it shows up as two generic DirectInput gamepads in Windows since there are two gamepad slots in it. My BIOS is version F13, downloaded from Gigabyte.
    – Cutter
    Oct 25, 2015 at 21:31
  • Another possibility is to setup a script for computer-idle that after a defined time will disable the gamepad and send the computer to sleep, and another on wakeup that will re-enable the gamepad. Would you be interested in such a solution?
    – harrymc
    Oct 25, 2015 at 21:32
  • The 2011 BIOS in my link is F14b, but updating the BIOS is always risky. If you brick the computer, it will take a professional to set it up again.
    – harrymc
    Oct 25, 2015 at 21:35
-1

Check:

a) Control Panel -> Power Options -> Change plan settings (next to whichever plan you have selected) -> Change advanced power settings -> USB settings -> USB selective suspend setting - set to Disabled

b) Control Panel -> Devices and Printers -> (right click on the game pad) Properties -> Power Management

If Windows allows, check the first box "Allow the computer to turn off this device to save power", and also uncheck the box "Allow this device to wake the computer".

2
  • 1
    I did that and the problem persists. Though the second checkbox "Allow this device to wake the computer" is disabled.
    – Cutter
    Oct 25, 2015 at 21:23
  • 3
    There is no "Power Management" settings when I go to properties on the xbox 360 controller under Devices and Printers. Jan 20, 2019 at 15:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .