13

Is there a way to prevent the second monitor to turn black when an application in the first monitor is made full screen? I have this problem in Mac.

  • 1
    there's not enough info in your question. What monitors? What connection type? What Mac and OS version? Please update. – SaxDaddy Sep 30 '15 at 17:11
18

Yes there is (And if you use a Mac, I also believe that there is enough information on the issue to answer the question).

Just go to System Preferences > Mission Control and check the option that says "Displays have separate Spaces".

Separate Spaces

That solves the issue on one monitor going black when there is an app on fullscreen mode in the other.

| improve this answer | |
  • 1
    Note that relogging is required for this to work. "Requires log out" is visible on the screenshot you're linking to, but not in the settings dialog I'm actually getting. – Morawski Apr 8 '16 at 9:41
  • 7
    Note that turning on "Displays have separate Spaces" prevents application windows from spanning more than one screen. You cannot have that and useful full screen on multiple monitors at the same time. OS X's multi screen/monitor/desktop and full screen implementation choices are fundamentally broken. A window manager add-on that does "manual" vs native full screen like Divvy is a reasonable workaround if the app doesn't have "special" full screen behavior you need. – Metaxis Jul 25 '18 at 1:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.