2

I'm using KDE 4.14. on Fedora 20 (sorry, it's not my choice). Now, when I use Alt+Tab, I get the task switcher. Keeping the Alt down, I can select a task using Tab keypresses to scroll right. But coming from Windows, I'm used to beingl able to use both Tab and Shift+Tab in this state to scroll left and right - and my KDE doesn't seem to allow this: Shift+Tab scrolls to the right as well.

I suspect this might have something to do with my keyboard layout:

I'm also using a dual-language keyboard layout:

xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(qwerty)" };
        xkb_types     { include "complete+caps(shift)+numpad(microsoft)"        };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include "pc+us+il:2+inet(evdev)+group(alt_shift_toggle)+terminate(ctrl_alt_bksp)"       };
        xkb_geometry  { include "pc(pc101)"     };
};

which causes keyboard behavior to act up a bit in other situations as well.

What should I do?

  • Have you checked the KDE hot-key bindings? Last time I used KDE, it had hot-key settings in the control panel (or whatever it is being called in KDE). – zagrimsan Sep 30 '15 at 10:49
  • @zagrimsan: It tells me Alt+Shift+BackTab should work, whatever that means. I can't change it from the default, it tells me that "That key is not supported by Qt". – einpoklum Sep 30 '15 at 11:31
0

On my system you need one finger more: use Alt+Shift+Tab to scroll left in the list of tasks.

It works even with 2 fingers only:
Alt+Tab , do not release the Alt and press Left Arrow or Right Arrow to go left or right.

EDIT
After your edit I find this link. What it follow it's just an hint.
You can try to backup your XKB customization file and to do some experiments.

With the command setxkbmap -types local -print on the system on which I am now, I obtain something similar to

xkb_keymap {
    xkb_keycodes  { include "evdev+aliases(qwerty)" };
    xkb_types     { include "local" };
    xkb_compat    { include "complete"      };
    xkb_symbols   { include "pc+us+il:2+inet(evdev)+terminate(ctrl_alt_bksp)"  };
    xkb_geometry  { include "pc(pc101)"     };
};

You can start with this one as your new custom file.
If it works you can modify what you need until you will find the option in conflict.

  • See edit. Shift+Tab doesn't work for me with Alt held down after Alt+Shift. However, +1 for the arros suggestion, that's something I guess. – einpoklum Sep 30 '15 at 9:52
  • @einpoklum. I added a link and a working configuration xkb_keymap. Good hunting. – Hastur Sep 30 '15 at 10:42
  • I'm not going to give up Alt-Shift toggling to avoid the problem - I need that even more... – einpoklum Sep 30 '15 at 11:28
  • @einpoklum So have you verified that Alt-Shift toggle triggers this (removing that would solve the issue)? – zagrimsan Oct 1 '15 at 6:55
  • @einpoklum The use of shift to logic negate a command is a general behaviour of KDE (e.g. Ctrl-Z and Shift-Ctrl-Z for Un-Do Re-Do)... I remember that to switch between 2 language layout I mapped the command with a different combination (something like Shift-CapsLock...) instead of Alt-Shift. If this is the problem I think you can find a lot of other not harmful combinations... – Hastur Oct 1 '15 at 8:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.