8

I have googled this issue and found a lot of problems like this for laptops but none for desktops.

My Windows 10 machine appears to being shutting down but then it does not. I use the start menu and then click power -> shutdown. I also use the shutdown button from the log in screen and it does the same thing. Just appears to be shutting down but never does. It does log me out though.

Command line shuts my PC down fine with "shutdown /s". This is not a solution. I want my power off(shutdown) buttons to SHUTDOWN my PC instead of logging me out.

Does anyone know how to fix this issue?

The proposed duplicate question deals with Win 10 shutdown problems, but different issues and the solutions do not apply.

  • 2
    possible duplicate of Windows 10 doesn't shut down properly – CharlieRB Sep 30 '15 at 14:43
  • Not a duplicate, read the question Charlie – user1567453 Sep 30 '15 at 23:46
  • No offense to you, so don't take this personal. There has to be 5 votes to close a question. If no one agrees with me, this will stay open. I voted as duplicate because they both have to do with Windows 10 not shutting down properly, regardless of what the platform. Neither question definitively isolate the architecture as being the cause. If you have proof it is specific to your computer being a desktop, then edit your question to include those details. – CharlieRB Oct 1 '15 at 1:04
  • @CharlieRB The title says it's for a desktop. My first sentence says it's for a desktop. The question you linked to talks about a laptop. The answers for the laptop talk about the sleep and hybernate and closing of the lid being issues. pretty clear mate. – user1567453 Oct 1 '15 at 1:36
11

To make the shutdown buttons shutdown the PC you have to change some settings in the power options.

  1. Navigate to Control Panel\All Control Panel Items\Power Options\System Settings
  2. Click on the text which says "Change Settings that are currently unavailable"
  3. Uncheck "Turn on fast startup (recommended)"
  4. click "Save changes" at the bottom of the screen
  • 3
    To be clear, Click on "Choose what the power buttons do" in Power Options. – allidoiswin May 19 '16 at 2:03
  • This is rare, I migrated the OS from a HDD to a SSD, and this problem appears with the SSD, not with the HDD. Hopefully, your solution fixes it (as expense of some slowness at shutdown) – sequielo Aug 16 '16 at 22:03
1

Try editing the Power options; also try shutting down using the shutdown command in the Run dialog Win-R:

shutdown -s -t 00

or, to force shutdown,

shutdown -f -s -t 00

If that works, copy it to a batch (text) file named myshutdown.bat (or any filename with .bat extension); create a shortcut in the start menu for convenience and to make a keyboard shortcut.

You can try the -h (hibernate) option, but it is deprecated, as MS seems to have found it unreliable since Windows 8.

  • DrMoishe, you are almost there. The answer is in Control Panel\All Control Panel Items\Power Options\System Settings. You have to click a button called "Change Settings that are currently unavailable" and then you uncheck "Turn on fast startup (recommended)" and click "Save changes" at the bottom of the screen. Then my desktop shuts down properly. If you alter your answer to highlight(put it at the top of the answer) what fixed my problem then I'll mark your answer as correct. It was the one which led me to the real solution at the end. – user1567453 Oct 1 '15 at 9:02
1

Starting with Windows 8, Microsoft changed the way how Windows boots to make it faster. This is called HybridBoot and is a logoff + hibernation. Next time Windows starts it resumes the kernel from hibernation and after login it starts your startup tools as in all older versions. To do a full shutdown you have to press the SHIFT key and press the Shutdown button.

0

Sorry if i am wrong as i haven't go through this situation.

If you are using Internet on your PC, then it might happen that OS get update as windows 10 is having alot of issues with Update, so shutdown take some time sometimes it happen that pc don't shutdown and after 2-3 minutes it automatically update your system. Might be that is the reason.

  • Nah, it was on for 5 days straight. No updates being applied or restarts. Just takes me to the log out screen. Power supply still running, fans still running, USB devices still running, Windows still running. All for days with multiple presses of the "shutdown" buttons. All sorted now as per my answer below. – user1567453 Oct 2 '15 at 5:25
0

To make the shutdown button actually shutdown the PC, I had to change some settings in the power options.

Follow these steps:

  1. Go to Control Panel → All Control Panel Items → Power Options → System Settings.
  2. Click on the text which says "Change Settings that are currently unavailable".
  3. Uncheck "Sleep". (This removes Sleep as an option in the Start Menu power options, but it solved the problem with shutting down, and I could still 'hibernate' if I wanted to)
  4. Click "Save changes" at the bottom of the screen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.