4

I have updated from Windows 7 Ultimate x64 to Windows 10 Pro x64 using Media Creation Tool.

After some weeks when I'm clicking on the start button nothing happens and the whole status bar becomes unresponsive. After trying to restart explorer.exe from Task Manager explorer.exe fails to initialize. It just shows the start button, Cortana and the search bar, TaskViewer (if that's how it is called) and the Action Centre button.

Any ideas?

I tried running:

  • sfc /scannow and no errors were found
  • chkdsk /f and no errors were found

A full system restart seems to do the trick but after some time like a few hours it stops responding again.

My configuration:

  • CPU is Intel i5 4690K OC-d to 4.5Ghz
  • GPU is AMD Radeon HD 7750 Saphire 1Gb GDDR5 Edition

EDIT: After some GOOGLE SEARCHING if i try to run from Task Manager C:\Windows i can actually open a window. The start bar isn't responding though and there are still no desktop icons or wallpaper.

  • I have checked for updates after a restart and there were no updates available – TermoZour Sep 30 '15 at 16:59
  • After some other GOOGLE SEARCHING i found out that some people had this problem also and they fixed it by deleting explorer.exe folder from regedit from HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution.options – TermoZour Sep 30 '15 at 17:00
  • But i don't know if i should delete that – TermoZour Sep 30 '15 at 17:18
  • Set a manual Windows system restore point, then try regedit, reboot and if there is trouble use the restore point to get it back where it was before deletion. – Moab Sep 30 '15 at 17:26
2

My brand new PC running Windows 8.1 had a problem with Explorer.exe not responding, and it persisted after I upgraded to Windows 10. In my case, explorer.exe didn't stop running, but the task bar was no longer updated (clock was behind, notification icons out of date), I couldn't use alt-Tab to move between windows and holding the mouse cursor over icons in the status bar didn't display the associated window. Finding 'Windows Explorer' in Task Manager, right clicking and selecting 'Restart' would resolve the problem, but only for a little while.

I created a System Restore Point then used regedit to delete the explorer.exe subkey from HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution.options and haven't had the problem since then.

I posted this mainly to clarify that the explorer.exe "folder" referenced above is in fact a subkey. I puzzled over the nomenclature for a moment before realizing what TermoZour meant, and thought I'd post this to help others who might misunderstand.

| improve this answer | |
1

After deleting the explorer.exe folder in regedit from

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution.options

explorer.exe never crashed after that.

EDIT: After a few months the same problem started again and this fix no longer works for me, but i will leave this answer here in case anyone else has the same problem.

EDIT2: I managed to fix it for good by reinstalling Windows 10 from a setup disk that you can download from their website. I selected to keep my data, and after the installation everything worked fine.

| improve this answer | |
  • I did it on my cousin computer and it crashed: black screen. Even, before of doing that I created another account and the same situation: black screen. – fredyfx Mar 4 '16 at 22:48
  • Maybe you deleted the wron registry keys. For me it didn't happen like that – TermoZour Mar 5 '16 at 4:54
  • Didn't work for me... – bashan Oct 2 '16 at 4:00
  • You can try installing the Anniversary Update that just launched. I never had any type of errors ever since – TermoZour Oct 2 '16 at 8:26
0

Since you upgraded from windows 7, there are a lot of installed components which could be causing this issue. Usually renaming the file to [original name].bak stops the crashing. The problem is how to know which is the component. Sometimes looking in the Event log might reveal it, but sometimes the crash happens in Explorer.exe and you need to dig deeper to find out which component it is loading which is causing it to crash. I wrote a post here on how to use Process Monitor to help figure it out.

It seems you already resolved this by reinstalling windows but I hope this helps others with the same problem.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.