4

I have successfully set up sleep and wake up tasks for Windows 7 that have functioned correctly for more than a month. After a upgrade to Windows 10 the wake up task has ceased working.

I have tried anything: sleep timers are on, hybrid sleep on/off, power settings are very permissive, with/without password and same for the logon screen. I have checked both event logs and schedule last runs and the task only fires just after I manually wake up my PC - sometimes not even then.

  • And your question is? – Francisco Tapia Sep 30 '15 at 19:24
  • 1
    My question is, if not obvious, how to wake my Windows 10 machine with task scheduler given the above stated scenario. – Răzvan Lazea-Postelnicu Oct 1 '15 at 9:27
1

Possibilities:

Windows 10 reverted a setting to disable sleep/wake timers in the OS

Check the advanced power options

GUI: Control Panel\All Control Panel Items\Power Options or Winkey+R > powercfg.cpl

CLI: powercfg (note options -availablesleepstates -devicequery -deviceEnableWake -lastwake)

Windows 10 caused a bug to be highlighted in a device driver

Industry specifications work as a guide so (hopefully) all pieces work together. Sometimes people make mistakes, are lazy, or are ignorant and things break. Microsoft may appear at fault when they really are not.

Check the manufacturer's website of your PC's hardware for updated drivers.

Windows 10 updated an existing driver that has a bug in it

Likely driver culprits that would affect this behavior could be:

  • Video graphics driver
  • Intel management Engine Interface (EMI) driver

Try upgrading/downgrading/reinstalling them.

Windows 10 has a bug in it

A day after Windows 10 Tech Preview was released in 2014, Microsoft released kb3010668 to deal with power/sleep issues so check for MS updates.

A device may be attached to the PC that is preventing the sleep/wake timers

Could be something like a printer left on or something else seemingly trivial like that.

You forgot you had modified the BIOS/UEFI to save money on electricity by turning off the wake timers without realizing they were related to the wake timers in task scheduler...

You could always try resetting the BIOS settings.

If all else fails....

enter image description here

| improve this answer | |
  • 1
    ITYM Alien Capacitors? – Andrew Morton Sep 30 '15 at 22:06
  • 1
    Flux Capacitors? For traveling back in time before I upgraded? I also suspect drivers. I'll test over the next day and get back to you. – Răzvan Lazea-Postelnicu Oct 1 '15 at 9:28
0

Your PC may have a power-on schedule in the BIOS. It's not what you want, but it might do what you need.

| improve this answer | |
0

Please go to Power option: Power Options -> Change Plan Settings" for the power plan you are using. Then select "Change advanced power settings". Next go to "Sleep -> Allow wake timers" and enable them there.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.