1

Since yesterday I was trying to kill hl2.exe (Team Fortress 2) process and:

  • Task Manager wont show that hl2.exe is running

  • Process Manager&Process Hacker 2 says "Access denied" When tried to kill the process.

<http://prntscr.com/8m9fi3>

  • Command Prompt says that there is no program running by the name of hl2.exe.

http://prntscr.com/8m9sbh

I opened Process Manager, Process Hacker 2 and Command Prompt as administrator but it still didnt worked.

I really ran out of ideas as to what I should do and I really need to fix this.

  • Restart your computer. – DavidPostill Sep 30 '15 at 19:05
  • Read it again: Process Hacker does not say "Access denied", it says "Attempt to terminate an exiting process". Also the command line does not say "There is no program running", it says "there is no running instance". That HL2 process somehow died but did not die completely yet. Maybe it's stuck in some Windows Error Reporting. – Thomas Weller Sep 30 '15 at 19:18
  • @ThomasWeller ??? What do you mean by Windows Error Reporting? This has been going on for like 3 days,and I never saw anything like that in Process Hacker 2. – siryuzu Oct 1 '15 at 12:25
2

Try taskkill /im hl2.exe /t /f. Be sure to run a command prompt with administrative priviledges (right click on the Start button, it should be one of the available options).

  • Didnt worked. Error says that there is no instance running by the name of that task. – siryuzu Oct 1 '15 at 12:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.