1

I have a wired home Gigabit Ethernet LAN with several PC's and other devices operating correctly over it and one WiFi N access point/switch/gateway.

I have installed another 802.11n access point (the second one) to have some signal coverage over the distant parts of my house. Those routers/switches are interconnected at wired Gigabit speed with no problem. The wired part of the LAN operation works flawlessly. And with only one access point, too.

The problem is when I try to configure the interoperatibility between those two WiFi hotspots. I am trying to make the wireless devices change transparently from one hotspot to the other, but they fail to do so.

They are (I thought) properly configured, same WiFi security settings (WPA2), same auth method (AES), same passphrase, etc. I have tried both settings: same channel (they are distant from one another) and different channels. No matter what I tried, the devices do not change automatically hotspots. When switching from one point to the other, they ask for the passphrase, recognizing the hotspot as a new one.

The conflicting devices are a TP-Link TDWR1043ND and a Mitrastar, connected by wire and acting as 802.11n hotspots. They have some settings to act as a bridge, but this is connecting wirelessly to one another, not through wire. But it should be no problem to interconnct them by wire, providing two areas of WiFi coverage.

What should I change to make them operate transparently (to have two Wireless areas of service on the same LAN)?

5
  • Do they have the same name? BSSID? Oct 1 '15 at 8:53
  • Yes, they do have the same parameters in all the common configuration options.
    – shirowww
    Oct 1 '15 at 10:00
  • Two APs should never have the same BSSID (only ESSID)…
    – user1686
    Oct 1 '15 at 10:36
  • Sorry, I meant they have the same ESSID (identifier name), not BSSID (MAC address).
    – shirowww
    Oct 3 '15 at 3:32
  • Getting clients to switch AP's automatically and seemlessly seems to me to be one of the most difficult wifi challenges. Keep in mind that most of the issue is with the client (device), not the router or access points. The client needs to decide it's time to switch, and many won't.
    – Tyson
    Nov 30 '15 at 15:09
1

You have to keep the same security settings on both APs, but put them on different channels.

Whether you need to keep the same ESSID or not depend on your clients.

By default, you should let them on the same ESSID.

However, as explained here and here in the caveat section, some clients do not switch automatically from one AP to another even if the signal looks better on the other one. This may be due to bad implementation in the computation of the signal level/strength (on the driver, firmware or hardware level, who knows?), or the second AP closer may have a less powerful signal than the other AP located far away. In that use case, you could use another ESSID and ask each client to connect automatically to the network if in range. In that use case, you'll be on the same network but via another SSID. This configuration is often used in hotels: one SSID different for each floor.

Also, make sure your ESSID is visible and not "hidden" (aka. passive move or network cloaking).

On a personal note, I have that same TP-Link router/AP and the latter is working flawlessly in such a configuration. I configured both of them on the same SSID and clients are connecting from one to the other without issues. I do not know how Mitrastar should behave. As a test, maybe you should replace that Mitrastar device with another AP (from a more popular trademark) reported to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.