10

I keep receiving the "Windows Smart Screen can't be reached right now" prompt when Installing software. I visited the Microsoft Community for support, but it only provides troubleshooting steps for connecting to the Internet.

My internet connection is working properly, so I don't know why the prompt is appearing.

  • Smart Screen requires the internet connection to work properly. If there is an internet issue preventing Smart Screen running correctly you can temporarily turn it off. See How to bypass "This app has been blocked for your protection" error – DavidPostill Oct 1 '15 at 10:06
  • 3
    Ya noted that it requires an Internet Connection that's why I asked here .I have a good Internet Connection and at the time of asking here I was installing a messenger through Edge later at which it gave this prompt. – user285oo6 Oct 2 '15 at 6:28
  • I received this notice while trying to install an application after having turned on "network discovery". I turned off "network discovery" and no longer received the notice. – ChronoFish May 6 '18 at 12:48
2

One possible cause is if a firewall is blocking Windows Explorer from accessing the internet.

Nothing in my applications list looked obviously related to Smart Screen, so when I had this error, I went through my firewall settings MS application by MS application. Windows Explorer is the one where it didn't work before I created an exemption allowing it to connect, and did work (or at least, didn't give this error) after.


(note: this is Windows 8.1, it might be different in Windows 10, but it's something to try)

2

First off - check the date and time on your computer to make sure that it is accurate.

If that doesn't work then your TCP/IP or Winsock stack could be borked and will need to be rebuilt.

Open a command prompt as Administrator.

  1. Type netsh i ip r all and press enter.

  2. Type netsh winsock reset and press enter.

Note: If you have set your computer's IP address as static on your network, you will need to reapply those settings as the TCP/IP reset clears these settings. Most people should be fine if they are using DHCP at home to connect. I wouldn't run these on any type of work computer though, because you'll probably have to annoy your IT department to fix the IP address settings up again.

  • This worked for me, although it could've also been the restart that fixed it ¯\_(ツ)_/¯ – Andrew Keeton Jan 5 at 1:55
  • I had this happen on another computer and this fixed it, too, this time without doing a restart (and it also fixed the Office 365 Unlicensed Product issue) – Andrew Keeton Jan 5 at 23:40
2

This happens when your private network is not set up. I am using wifi, so I will tell you how I fixed this issue on a computer connected to wifi.

How to fix:

1) Click on the wifi icon in the taskbar, it will open the window with wifi connections

enter image description here

2) The network highlighted in purple is mine. Next click on properties. It will take you to this window: enter image description here

mine is set to "Private", because I have already reset it, but yours is set to public and that is why your smartscreen can't be reached, because it doesn't use untrustworthy public networks and only works with private networks. Reset to private and your smartscreen will work again.

Do not just set any network to private, because you can compromise the security of your computer. Choose only the one you trust.

  • 1
    I just set up a fresh install, and my Wi-Fi network was set to Private from the outset, yet this issue occurs. So there's clearly a different cause here. – David Metcalfe Jul 23 '18 at 17:31
0

Have you tried opening the command prompt as admin and running.

ipconfig /release
ipconfig /flushdns
ipconfig /renew

I usually have this problem if airplane mode or Bluetooth was turned on for awhile then turned back off.

0

they changed it into a setting called "App & browser control" search in settings and you will find it

0

On Windows 10, You may turned off SmartScreen feature in settings. Open Windows Defender Security Center > App and browser control. Here check that the SmartScreen settings are set to their defaults:

Check apps and files: Warn
SmartScreen for Microsoft Edge: Warn
SmartScreen for Windows Store apps: Warn

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.