1

I have upgraded my Macbook Air CTO 8Gb ram (mid 2015) to El Capitan. After that the USB ethernet adapter don't working... first always said cable unplugged, after i removed the interface i can't add back. I also tried to reinstall the moschip usb driver and edit the /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist but no luck.

UPDATE Finally I find this in console: 01/10/15 14:40:12,461 com.apple.kextd[45]: ERROR: invalid signature for com.moschip.driver.moschipUsbEthernet, will not load

I googled it and run:

sudo nvram boot-args="kext-dev-mode=1 rootless=0"

then booted to recovery mode (hold command + R at boot)

and in terminal run csrutil disable

reboot and then driver loads again... huhh :)

1

Short answer, Apple's new "System Integrity Protection" (SIP) prevents any modifications to system files, as well as unverified kernel extensions.

Those drivers are using unverified extensions, and are blocked.

For the moment csrutil disable in recovery mode is the only solution. But - it disables SIP system-wide. It's probably worth asking if you'd rather spend $20 for a legit adapter and keep your system secured.

Long answer with step-by-step instructions: How to use a Generic USB 2.0 10/100M Ethernet Adaptor on Mac OS 10.11 El Capitan

| improve this answer | |
0

I did the sudo nvram boot-args="kext-dev-mode=1 rootless=0" followed by rebooting in recovery mode and csrutil disable. After I do csrutil disable I get a success message and it tells me to reboot.

However, when I'm back in the OS, I do csrutil status and I get this.

System Integrity Protection status: enabled (Custom Configuration).

Configuration:
    Apple Internal: disabled
    Kext Signing: disabled
    Filesystem Protections: disabled
    Debugging Restrictions: disabled
    DTrace Restrictions: disabled
    NVRAM Protections: disabled

This is an unsupported configuration, likely to break in the future and leave your machine in an unknown state.

My usual USB network connection still says the cable is unplugged (it isn't) and there isn't anything on the + menu for me to add different.

Any tips?

| improve this answer | |
  • 1
    Welcome to Super User! This is not an answer to the original question. If you have a new question please ask your own question (referencing this one for context if it helps). – DavidPostill Oct 8 '15 at 15:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.