I've got an HP PSC 2410 printer shared from a fresh Ubuntu 9.10 installation. I'm able to send documents to this printer over the network from another Ubuntu machine. But so far, I haven't been able to find a setup where I can send documents to that printer from a MacBook running 10.5.7.

On the Mac side, when setting things up, I go into System Prefs > Print & Fax, click on the "+" mark, select "IP", pick "IPP", enter the IP address of the Ubuntu box, leave the queue blank, enter the Name and location, and I think it's when I get to the "Print Using" (driver selection) part that I'm running into issues.

If I use "Auto Select", it defaults to "Generic PostScript Printer", which I doubt the PSC 2410 is (and sure enough, if I print, the jobs don't go through).

If I try "Select a driver to use...", there's not an option for an HP PSC 2400. This seems a little odd: I can plug the printer directly into one of our Macs and it immediately figures out the driver and I can print no problem, but that's apparently the way things work.

So, that leaves one option: "Other", which, when selected, brings up a dialog apparently for the purpose of manually locating a driver. I've tried visiting HP's web site. They have drivers for earlier versions of Mac OS X, but state that after 10.4, Mac OS X should just come with the relevant drivers.

I've also tried setting things up by interacting with the CUPS server on the Mac through a browser: I go to http://localhost:631/, select "Add New Printer", pick "Internet Printing Protocol (http)" for the Device selection, enter "http://ubuntu.machine.ip.address:631/printers/hp-psc-2400-series" for the Device URI, select "HP" for Make, and then on the next screen, we're back to the problem where the PSC 2400 just doesn't show up. There's an option to "provide a PPD file", which I assume would be the printer driver I can't find.

A Google search for "HP PSC 2410 ppd Leopard" doesn't seem to yield much other than a reminder that the printer is supposed to just work out of the box on Leopard. A local search for ".ppd" or "2410" on either Mac also doesn't yield anything that looks like a relevant print driver.

I'm totally stuck at this point. Any advice?

1 Answer 1


To follow up, I got a pointer to an answer in another forum:

It turns out that Mac OS X 10.5 doesn't listen by default to CUPS broadcasts that advertise network printers running on other CUPS servers. So, on a terminal session at the Mac, just type

cupsctl BrowseProtocols='"cups dnssd"'

and then all printers will show up on the Add Printers dialog.

(From http://forums.macrumors.com/showthread.php?t=677238#3.)

I did this on the Macs on question and it worked like a charm: I typed in the cupsctl command, pulled up the Add Printers dialog, switched from IP to Default, and there it was. Mac OS X figured out the driver, and everything went smoothly.

There's also some indication that it might be possible to use Bonjour on Ubuntu to make the CUPS-shared stuff visible, but I'm not clear on the details.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .