10

I can't change any settings nor install anything using the xfce GUI on my xubuntu 14.04. Some setting-windows have that unlock button you usually click to enter your password to gain root privileges, but nothing happens if i click on them:

enter image description here

When starting up that machine, it asks for the installation of language stuff. When I try to install that, I get this error:

enter image description here

How can I fix this?

EDIT:
I just tried to start /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 as suggested here but it fails:

xubuntu-pool-1 vm-admin # /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 

(polkit-gnome-authentication-agent-1:3863): GLib-CRITICAL **: g_variant_new_string: assertion 'string != NULL' failed

(polkit-gnome-authentication-agent-1:3863): polkit-gnome-1-WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

EDIT2:
Actually, it doesn't seem to fail. It doesn't return to the bash prompt but the unlock and install doesn't work anyway.

Edit3:
I also made sure that "PolicyKit Authentication Agent" is checked in startup.

Update:
I just found out, that this issue only happens when logged in via xrdp. If I'm on the local vmware console (this machine is virtual), it works just fine. So the issue must have something to do with xrdp.

Output of that polkit command using normal user:

$ /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1

** (polkit-gnome-authentication-agent-1:4540): WARNING **: Unable to register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Cannot determine user of subject
Cannot register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Cannot determine user of subject

This output is the same for the command beeing run without and with sudo.

11
  • Is PolicyKit Authentication Agent checked in Startup Programs? SImple but it can create the problem. – Hastur Oct 5 '15 at 17:29
  • Try the command in your EDIT with sudo. – harrymc Oct 5 '15 at 20:06
  • @Hastur yes, it is. – wullxz Oct 5 '15 at 21:37
  • @harrymc I did that as root as you can see by the "#"-sign in my bash prompt. – wullxz Oct 5 '15 at 21:37
  • Yes, I should have. You problem is exactly the same as in this thread, although for Ubuntu 13.10. Could you try and report on the suggestions mentioned in there? – harrymc Oct 6 '15 at 8:00
0

It might be a bug and I'm not sure how to reverse that, but here's an idea: Perhaps you can create a new administrator account, verify your settings are working properly and port your data over to the new account, gaining access that way. I've been locked out my OS's in the past, that trick has worked sometimes and I'm not the only one apparently:

Ubuntu Forums

It may not work, but if you have no other option, might be worth trying. Best of luck in any case.

0

I think your link from your first edit is promising. pleas do NOT start it as root! And start it FROM AN X environment like xterm (not from the text console!).

echo DISPLAY=$DISPLAY

should at first normally output "localhost:0". Then try it again:

/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1

also check, whether the suid bit or so is set on it:

ls -l /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1

should perhaps result in some "s" flags instead of x perhaps like this "srwxr-xr-" i guess...

1
  • 1
    I found out that this issue only happens when remotely connected via xrdp. It works fine when I'm on the vmware console (like beeing local - it's a vm). Any Idea? I also ran the polkit command again on xterm in a xrdp session - I'll add the output in my question. – wullxz Oct 8 '15 at 12:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.