I've been running a VM with OSX for a while now while developing for iOS using an iPhone device. Everything was working fine until the update to El Capitan. Since the update, the iPhone is no longer being recognized by the VM-OSX (this includes iTunes, Xcode and AppCode).

The iOS device is definitely connected to the VM and not to the host computer, and I have clicked the "Trust this computer" in the popup which appears when plugging it into the usb for both the host and the VM.

Any idea what can be done about this other than going back to Yosemite?

Thanks in advance!

System configuration:

  • Host OS: Windows 10 Pro 64-bit.
  • VM OS: OS X El Capitan v10.11.
  • VMWare Workstation 11.1.2 (patched to support OSX).
  • iPhone 6, running iOS 9.0.2.
  • iTunes
  • IDE1: Xcode 7.0.1 (7A1001).
  • IDE2: AppCode-OC (EAP) 142.5239.5.


Following the example of this question, the device does appear in the hardware list: Devices list


As discussed in this thread, a faulty AppleUSBEthernetHost.kext that was present on my system (v8.0.1) may have been the cause of the problem. I tried replacing it with an older version (7.0).

These are the steps I took:

  1. Booted into recovery to disable the System Integrity Protection (aka "SIP") by holding WinKey+R during VM boot (which is being mapped to Command+R by VMWare, according to this answer).
  2. When in recovery, I entered the terminal utility and disabled SIP using the command csrutil disable as described here, followed by a reboot.
  3. Replaced the kext with the old version, which was obtainable at the time of writing using the method detailed here (in short: download the latest iTunes dmg; open it with Pacifist; install the subpackage manual\MobileDevice.pkg) and rebooted (to ensure the right version was being loaded).

This action did not fix my problem.


1 Answer 1


Inspired by this thread, where the new USB handling system introduced in El Capitan was discussed, I've attempted a very simple settings change in my VM configuration that managed to resolve the problem for me:

VMWare USB settings change

Since my device was connected through a USB2 port anyway, all it took was to tell the VM to treat the port as such.

I'm aware that this solution is not perfect, as it might hurt the transfer rates of USB3 communications, but what it lacks in performance it makes up in simplicity :)

Note: You will need to shutdown your VM, change the USB compatibility setting and restart for the change to take effect. Disconnect the iPhone/iPad from the host while doing this, just in case

  • 1
    I also helped me, even I have all USB 3.0 ports on mu iMac... So, it seems it works only with USB 2.0. Thank you!
    – Worker
    Dec 24, 2015 at 20:10
  • 1
    @Dev-iL - So this allows you sideload/ develop apps from Xcode to iPhone while in a VM?
    – Alex S
    Feb 29, 2016 at 18:05
  • 1
    @AlexS That is correct.
    – Dev-iL
    Feb 29, 2016 at 18:06
  • 3
    @AlexS - Just tested this on VMware workstation 12.1.0 + Xcode 7.2.1 + iOS 9.2.1 (iPhone 6) + OSX 10.11.3 - still works, as expected :)
    – Dev-iL
    Mar 4, 2016 at 18:31
  • 3
    Did anyone encounter this issue with VirtualBox? I see the device in same list as the author but it is not detected by Xcode or iTunes. I tried USB 1.1, USB 2.0 and USB 3.0. Nothing works, any ideas? Jul 9, 2017 at 11:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.