Since the installation of Kaspersky AntiVirus 2016 every website I visit contains this line in <head>:

<script type="text/javascript" 

On every site, the same GIUD is used. How can I disable this behaviour?

The code is injected in SSL pages, too.

  • I wonder how Kaspersky Labs explain this... AntiVirus software became too much clever. BTW do they inject this on SSL pages too?
    – POMATu
    Commented Oct 4, 2015 at 9:40
  • 2
    Yep, SSL pages are injected, too.
    – tjati
    Commented Oct 4, 2015 at 9:52
  • 1
    Disable the option that protects SSL traffic, doing so, will likely also disable it modifying insecure traffic as well
    – Ramhound
    Commented Oct 4, 2015 at 12:28
  • This is either "SSL Inspection," or a Man-In-The-Middle (MiTM) attack, depending on how you feel about your AV seeing every password & credential you send over HTTPS.
    – Mac
    Commented May 29, 2018 at 12:23
  • But perhaps the most compelling reason to disable Kaspersky's scanning of encrypted connections is because it drops the connection down from TLS 1.3 to 1.2
    – Mac
    Commented May 29, 2018 at 12:27

9 Answers 9


There is a setting to disable script injection in the newest Kaspersky version (>16.0.1):

Settings -> Additional -> Network -> Inject scripts into web traffic to interact with web pages.

  • If you can't find it: Update 16.0.1 (Maintainance Release 1) is currently only available in English. Commented Feb 22, 2016 at 13:55
  • Latest English version is i.imgur.com/EXkon6Q.jpg
    – Dims
    Commented Mar 28, 2016 at 9:21
  • 1
  • this did not do the trick and the script is yet injected on every web page
    – behz4d
    Commented Nov 3, 2016 at 14:21
  • @behz4d - You must be using a different version than the author.
    – Ramhound
    Commented Nov 8, 2017 at 13:55

I found a solution that worked for me:

Kaspersky application

Settings Page

select "Additional" section on left side

select "Network" settings

Monitored Ports

[ ] Monitor all network ports

[X] Monitor selected ports only Select...

Click the Select... link

  • Remove: HTTPS on port 443
  • Remove: HTTP on port 80
  • Remove: any/all other HTTP if you use those frequently
  • Bottom of the list, UNCHECK "Monitor all network ports..."

Close the Network Ports window

Close the settings window

Restart your browsers...

  • This one helps when using Kaspersky < 16.0.1
    – thasmo
    Commented Apr 15, 2016 at 22:05
  • I have tried this solution in KIS 16 and it works after restarting the browser (chrome as well as firefox). Dont forget "Bottom of the list, UNCHECK Monitor all network ports...". This is the last time I bought this AV.
    – Stefan
    Commented Oct 27, 2016 at 9:12

you can add these to C:\Windows\System32\drivers\etc\hosts    gc.kis.scr.kaspersky-labs.com    # Kaspersky anti-injection for Google Chrome    ff.kis.scr.kaspersky-labs.com    # Kaspersky anti-injection for Mozilla Firefox    ie.kis.scr.kaspersky-labs.com    # Kaspersky anti-injection for Internet Explorer


  • Now you also need to add gc.kis.v2.scr.kaspersky-labs.com because instead of solving the problem, they clung to that suspicious practice and changed the script URLs.
    – RedGlyph
    Commented Jan 18, 2020 at 23:38

As a quick workaround you can just disable that host in hosts file.

Put gc.kis.scr.kaspersky-labs.com        



You will need admin rights and maybe notepad++ to edit this file.

How it works

Kaspersky AV seem to transparent proxy the traffic. If they do that on https pages too this means that Kaspersky AV have also installed root certificate to your system.

By putting the line to hosts you are blocking the connection to that hosts, so JS file is not loading (but the code would still be on that page).

I am not familiar with Kaspersky AV options, but if there is no option in settings you'd better don't fight with software that you installed yourself on your pc. If you don't like it - change it, otherwise accept it.

Because even if you remove root certificate - the software would install it again. And I don't know the way how you can block transparent proxy if there is no such option in settings.

Also another tips:

  • Check browser proxy settings maybe it's not transparent proxy, but a usual proxy setting and you can just change browser settings
  • Check browser for plugins, maybe you can just disable Kaspersky AV plugins if there are any

I personally prefer old antivirus versions (with newest database updates of course), because they do only what they should do and nothing more. They are not uploading "suspicious" files to their servers and not injecting anything.

Also I recommend anyone to buy only "AntiVirus", but not "InternetSecurity" or something like that, because that things cost a lot, don't work, slows your browser, and sometimes do some really suspicious things.

  • I would just stay with 2015 unless there is another reason to get 2016. I usually wait until the beginning of the labelled year, which also allows for some patches to get released. Or ask them if it is possible to disable, though I imagine they would say "Sorry".
    – user3169
    Commented Oct 5, 2015 at 3:24

I've found the source of these JS files. They are in plugins_facade.dll in Kaspersky dir. Just go ahead and delete the dll file. I did it and it worked!


This worked for me!

In Kaspersky select

Settings -> Additional -> Network -> Do not scan encrypted connections

AND make sure this option is checked

Monitor selected ports only

From the "Select..." option make ports 80/443 edit -> inactive

I had to make both these changes for it to work. Also make sure to restart the browser for the changes to take effect.

I couldn't find the 'Inject scripts into web traffic to interact with web pages' option which may be available in newer versions.

I wouldn't recommend the "hosts" solution since it doesn't stop the script from being injected in the first place which is the main problem for web developers.


I contacted customer support. They understood the concerns that web developers have with injected Javascript. They had no timeframe for a fix. I asked for and got a refund.

  • 2
    They have no timeframe for a fix == They're never going to fix this. Kaspersky stick its nose too deep in its customers' computers, and this way they lose customers, like you in this case. I once tried to completely uninstall all traces of Kaspersky and found it an impossible task. Commented Nov 7, 2015 at 19:33
  • 1
    Heh. tldr: You can't for now and for the foreseeable future. Seems like a valid answer to me.
    – Journeyman Geek
    Commented Nov 7, 2015 at 23:02

Follow the screenshot instruction on the latest version.

enter image description here


The easiest way to block these injection is to install a plugin called Privacy Badger.

  • It's not the easiest way. See the accepted answer for the proper solution.
    – DavidPostill
    Commented Aug 20, 2016 at 7:34
  • 1
    Please read How do I recommend software for some tips as to how you should go about recommending software. You should provide at least a link, some additional information about the software itself, and how it can be used to solve the problem in the question.
    – DavidPostill
    Commented Aug 20, 2016 at 7:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .