I have a standalone version of IrfanView (x64) and want it to appear in the Open With menu for all image files. I do not want it to be the default program however. For some reason no matter what I do, it doesn't want to enter this list. It doesn't even appear in the 'more apps' menu after clicking Open With. Here are the things I tried (in no particular order):

  • Opening the file with IrfanView
  • Assigning IrfanView as the default application and then re-assigning the previous app
  • Following the instructions here: Add items to the "Open with" list in Windows 8 (the relevant registry key already exists!)
  • Downloading Default Programs Editor (it doesn't seem to have this option, and I don't want to add an "Edit with IrfanView" shell option)
  • Following the instructions here: http://www.sevenforums.com/tutorials/178066-open-add-program.html (the problem is that the site hosting the relevant app appears to be permanently down)
up vote 5 down vote accepted

I think you should retry Default Programs Editor.

Don't click on "Context Menu" but rather on the option at the bottom - "Change'Open with' programs":

enter image description here

and then:

enter image description here

You may need to restart you computer for changes to appear.

  • It worked, no idea how I missed that link at the bottom. – Ynhockey Oct 7 '15 at 11:49
  • 1
    Strange issue: all three programs I want actually show up in there, but Windows itself only shows 2 of them, no matter what I do... – Nyerguds Feb 8 '16 at 9:24
  • 1
    @Nyerguds: That seems to be a bug of Windows 10. See this answer how to solve the problem. – Robert Oct 6 '17 at 20:36

I ran into a special case that required some alternate steps and wanted to share it in the likelihood that someone else runs into the same problem:

So I wanted to fix Visual Studio 2013 and 2015 not appearing in the initial Open With list for .sln files; only 2017 and 2010 (the later of which has never even been installed on this machine). Imagine my frustration when, according to Default Programs Editor, everything I want is already in the list.

And they in fact were already in .sln's OpenWithProgids, but it turns out MS invented a new AllowSilentDefaultTakeOver registry value for file classes in Windows 8 that maybe does a few things, but among them seems to be preventing a program from showing up in the initial Open With list; because as soon as I removed the AllowSilentDefaultTakeOver value from the VisualStudio.sln.12.0 and VisualStudio.sln.14.0 keys under HKEY_CLASSES_ROOT, Visual Studio 2013 and 2015 finally showed up.

And just to be sure, I added AllowSilentDefaultTakeOver to the useless Visual Studio 2010 class, and lo, it disappeared from the Open With list!

So, if it seems like you've tried everything to get a program to appear in a file type's Open With list and it's just not working, look for an AllowSilentDefaultTakeOver value in HKEY_CLASSES_ROOT\[program's file type ProgID]. (Though, realistically, you'll probably only see this on older versions of Microsoft programs when you also have a newer version installed.)

  • I had the same issue of only 2010 and 2017 showing up and trying everything to get 2015 to show up. I removed the "AllowSilentDefaultTakeOver" from the "VisualStudio.sln.14.0" classes and finally the 2015 open shows. Thanks! – Tomas Jul 10 at 15:07

Another excellent tool is OpenWithView, by Nir Sofer.

It is very much worth checking his other free tools.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.