7

Ever since installing my new motherboard (Asus Z77 professional) my computer won't stay asleep for more than a few minutes. Executing powercfg /lastwake always returns the same:

PS C:\WINDOWS\system32> powercfg /lastwake
Wake History Count - 1
Wake History [0]
  Wake Source Count - 1
  Wake Source [0]
    Type: Device
    Instance Path: PCI\VEN_8086&DEV_1E1E&SUBSYS_1E1E1849&REV_C4\3&11583659&0&E7
    Friendly Name:
    Description: PCI-to-PCI Bridge
    Manufacturer: (Standard system devices)

From what I could find online, this device is either an audio controller or USB controller. I made sure to uncheck 'allow this device to wake the computer' for all devices but it still wakes up quickly after going to sleep.

Only when I unplug everything except for power, does the computer actually stay asleep.

I want to use Wake on LAN, so any solution that doesn't disable that would be welcome.

  • 2
    The PCI\ven is a PCI express slot device. If you run a dxdiag from the command prompt, then "save all information" to a text file where you can find that pci\ven in the list and possibly the associated driver which may give you a clue as to the actual device, – Moab Oct 4 '15 at 12:30
  • Often it is also because of the Video Card Driver. I have had same problem. But after reinstalling GPU-driver, it just has been solved. Windows Updates install sometimes drivers that are causing this kind-of problems – LowLevel Mar 30 '18 at 15:41
2

I have the same symptom.

I am more familiar with linux so I did an lspci.exe -vvv to see the tree view of the PCIe structure. I determined that there were only a few devices with the C4 rev listed. It was the "1c." devices. So I did an lspci.exe -tv to see the tree view of the devices:

PS C:\Users\Taylor\Downloads\pciutils-3.5.5-win64> .\lspci.exe -tv
-[0000:00]-+-00.0  Intel Corporation 2nd Generation Core Processor Family DRAM Controller
           +-01.0-[01-04]----00.0-[02-04]--+-08.0-[03]--+-00.0  NVIDIA Corporation GK104 [GeForce GTX 670]
           |                               |            \-00.1  NVIDIA Corporation GK104 HDMI Audio Controller
           |                               \-10.0-[04]--
           +-02.0  Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller
           +-14.0  Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller
           +-16.0  Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1
           +-1a.0  Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2
           +-1b.0  Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller
           +-1c.0-[05]----00.0  Intel Corporation PCIe Data Center SSD
           +-1c.5-[06]----00.0  ASMedia Technology Inc. ASM1062 Serial ATA Controller
           +-1c.6-[07]----00.0  Qualcomm Atheros AR9462 Wireless Network Adapter
           +-1c.7-[08-10]----00.0-[09-10]--+-01.0-[0a]----00.0  Broadcom Limited NetLink BCM57781 Gigabit Ethernet PCIe
           |                               +-04.0-[0b]----00.0  ASMedia Technology Inc. ASM1062 Serial ATA Controller
           |                               +-05.0-[0c]----00.0  Broadcom Limited NetLink BCM57781 Gigabit Ethernet PCIe
           |                               +-06.0-[0d]--
           |                               +-07.0-[0e]----00.0  Etron Technology, Inc. EJ188/EJ198 USB 3.0 Host Controller
           |                               +-08.0-[0f]----00.0  Etron Technology, Inc. EJ188/EJ198 USB 3.0 Host Controller
           |                               \-09.0-[10]--
           +-1d.0  Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1
           +-1f.0  Intel Corporation Z77 Express Chipset LPC Controller
           +-1f.2  Intel Corporation 7 Series/C210 Series Chipset Family 6-port SATA Controller [AHCI mode]
           \-1f.3  Intel Corporation 7 Series/C216 Chipset Family SMBus Controller

I change my Device Manager view to sort by "Devices by connection". This allowed me to look at the PCI-to-PCI bridge and see the sub devices, in a similar fashion to the lspci -tv. From here I saw the same subdevices.

By right clicking a few of the PCI-to-PCI Bridges above the subdevices and clicking properties I am able to look at the "Details" tab and the property "Device instance path". I was able to find a matching Device instance path to the same listed in powercfg -lastwake.

The network connection subdevice is not allowed to wake anything, so my next best guess is something plugged in via the USB that are a subdevice to the bridge we determined.

Due to having some gaming accessories I have a lot of HID-compliant devices that have the power management option to not allow waking. I turned them all off and it solved my problem.

The catch is that I can't use my keyboard to wake up the computer anymore, so I would have to go figure out which one(s) to turn back on as there were multiple keyboards listed.

| improve this answer | |
2

I had a similar problem, my computer was waking up after a few seconds every time I'd put it to sleep. The culprit waking device was the Intel built in ethernet adapter DEV_153B connected via a PCI bridge VEN_8086 on the motherboard. Although to the sources I looked up online, who pointed to an USB controller...

The solution to the problem looks simple, if you know it...

  1. goto device manager and doubleclick on your Intel Ethernet Connecton I2017-V
  2. goto the power management tab (screenshot)
  3. uncheck wake on pattern match (!)
  4. hit ok and do the test

If your power management tab looks diffrent see you have installed the official Intel driver insteat of the one that comes with Windows. For me only the first checkbox wake on magic packed is checked in the WOL box. Make sure the others are unchecked.

Wake Source [0]
  Type: Device
  Instance Path: PCI\VEN_8086&DEV_153B&SUBSYS_153B1849&REV_05\3&11583659&0&C8
  Description: Intel(R) Ethernet Connection I217-V
  Manufacturer: Intel

screenshot

screenshot

| improve this answer | |
  • 1
    I had almost the same issue, while powercfg -lastwake was pointing to "USB Root Hub", I solved the issue following your advice. My comment just to report a power management tab variation: my adapter is Intel 82579LM Gigabit Network Connection and I had to check a Only allow a magic packet to wake the computer option – ciarpame Jun 17 at 22:06
0

Oftentimes it's the network adapter(s) that causes the computer to wake up, so you might want to go to Device Manager > select Network Adapter(s) > go to Power Management > uncheck "allow this device to wake up..."

| improve this answer | |
  • 1
    This is a good solution for some, but the original poster said he would like to keep Wake on LAN functionality if possible. – Simon East May 20 '16 at 1:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.