I have installed Hyper-V from Windows Features but when i open Hyper-V Manager and try to create a Virtual Switch i get this error (NONAME is the computer name):


I read over the internet for solution but I don't find anything that solve my problem. I have checked at the Ethernet properties option "Hyper-V Extensible Virtual Switch" but error still show up. Also I tried to uninstall and install again the Hyper-V Manager but also nothing happened.I have Windows 10 Pro and is clean installation. Any ideas what to do?

  • Please edit your question to indicate the specific version and edition of Windows you are using.
    – user
    Oct 4, 2015 at 13:03
  • From the title bar, I deduce this is about Windows 10. Please fix it if this is wrong. Also, is it a clean installation or an upgraded installation? Was Hyper-V installed before upgrading?
    – Daniel B
    Oct 4, 2015 at 13:05
  • I have Windows 10 Pro and is clean installation
    – Tack
    Oct 4, 2015 at 13:11

3 Answers 3


In ran into the same symptoms after a Windows 10 update, and re-installing the network adapter didn't help. However executing the following command in a PowerShell console fixed it:

New-VMSwitch VMSwitch -NetAdapterName Ethernet

This seemed to repair the network switch configuration so after this the Virtual Switch Manager started successfully and I was able to use it to remove and create virtual switches at will.

  • 1
    I'm having the same issues. When running the above command. I get the following error: CategoryInfo: NotSpecified: (:) [New-VMSwitch], VirtualizationException FullyQualifiedErrorId : OperationFailed, Microsoft.HyperV.PowerShell.Commands.NewVMSwitch Mar 17, 2020 at 14:32

Try to uninstall the network adapter from the device manager, and install it again.

In most cases, after that, Hyper-V can create the virtual switch.


I was unable to open the Virtual Switch Manager and use Docker. Solved it by:

  • Turn Windows features on or off > uncheck Containers and Hyper-V
  • Reboot
  • Turn Windows features on or off > check Containers and Hyper-V
  • Reboot

Hyper-V Manager's Virtual Switch Manager and Docker then worked correctly.

Not the answer you're looking for? Browse other questions tagged or ask your own question.