0

I bought Brother MFC 7460DN and wanted to print things wirelessly. The printer itself does not have Wifi, so I wired it to my router.

Things I have tried:

  • reset the printer's network setting
  • upgraded its firmware
  • updated driver for my computer (I am using a mac, os Yosemite)
  • downloaded BRAdmin Light (provided tool to look for network printers) and tried to find the printer, but no luck
  • tried to look for it using a PC, but still no luck

Seems like the printer itself is not configured to the network correctly, but I might be wrong. I did read the manual, but there were too many useless information and I did not find any solutions. Any help will be appreciated. Thanks.


UPDATE:

I printed user settings and found that no ip was issue. I did not touch anything, what changes do I need to do?

Here is the information I got:

  • boot method: AUTO
  • ip address: 0.0.0.0
  • subnet mask 0.0.0.0
  • gateway 0.0.0.0
  • wins config: 0.0.0.0
  • wins server primary 0.0.0.0
  • wins server secondary 0.0.0.0
  • DNS Server primary 0.0.0.0
  • DNS Server secondary 0.0.0.0
  • APIPA: on
  • ipv6: off
  • ethernet auto
  • 99% of the time on a normal LAN, if you're not getting an IP address, its not plugged in properly. Check the cable at both ends; if possible, plug it directly into the switch/router for testing. – mikebabcock Aug 1 '17 at 19:02
1

Start by printing out a configuration page, which will tell you the printer's IP address. To print a configuration page, follow the steps below.

  • Press the Menu button.
  • Press 4 for "Print Reports."
  • Press 5 for "User Settings."
  • Press the Start button.

To test it, try pinging the printer. This should work if the printer and mac are on subnets connected by the router.

On the Mac, go to Apple menu > System Preferences, then click Printers & Scanners. If you don't see your printer listed, click the "+" at the bottom of the list. It should now show your printer. It may take a minute or two for your printer to appear. Select your printer when it appears in the list, then click Add. If you see a message prompting you to download new software, make sure to download and install it.

|improve this answer|||||
  • I noticed no ip was assigned after I printed the user setting. I updated my post. – Alex Oct 5 '15 at 23:35
  • 1
    It looks as if the printer is not getting an IP address. Is the link light on at the back of the printer? Is the printer set to use DHCP (but Boot method AUTO should use DHCP I think)? Is there a DHCP server on your network? You can enter an IP address manually, from the front panel. – hdhondt Oct 6 '15 at 4:20
  • I am quite a newbie, should I setup everything manually, or just the ip? what about other ones? – Alex Oct 6 '15 at 5:08
  • The IP is most important. You can also set the gateway (the router's address). The printer should set the rest automatically - and lots of it is rarely needed anyway.Do you know the IP addresses of the Mac and the router? For simplicity the printer should be on the same subnet (the same first 3 numbers), but that depends on your network setup. – hdhondt Oct 6 '15 at 22:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.