1

I'm working on a docked HP ProBook 650 and two external monitors.
On Windows it works fine, but my work requires me to use Linux (tried both Ubuntu and Debian).

Got two seperate problems:

  1. On Ubuntu all three monitors work - but my graphics twitch and break.
  2. On Debian only one monitor can be active others are in "disconnected" state

I've searched and tried a lot of things - but since I'm a novice in using Linux operating systems I'm seeking help on how to solve any of those two problems?

Or a suggestion for a better Linux option for a work station would be handy as well?

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Mars [Radeon HD 8730M]


xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
eDP1 connected primary (normal left inverted right x axis y axis)
1920x1080 60.01 + 59.93 40.00
1680x1050 59.95 59.88
1600x1024 60.17
1400x1050 59.98
1280x1024 60.02
1440x900 59.89
1280x960 60.00
1360x768 59.80 59.96
1152x864 60.00
1024x768 60.00
800x600 60.32 56.25
640x480 59.94
VGA1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)

1

The outputs you display above only report the existence of one monitor, not two. If you have given the above commands when you had both external monitors connected to your pc, then most likely there is a driver problem. You will have to investigate this by sifting thru the error messages in /var/log/Xorg*.

The reason why I am saying this is that X is, by now, essentially self-configuring, so if anything fails, it is most likely due to the absence of some essential component.

You may at any instant try to allow X to reconfigure itself by means of

       sudo dpkg-reconfigure xorg  

Alternatively, you may follow the ever helpful Arch Linux wiki about MultiHead (which is the configuration you are attempting). But do not be confused, all Linux distros use X, and are thus strictly equivalent in coping with your configuration.

  • Yeah, appered to be a driver problem. Managed to sort it out. Thank you. – user505434 Oct 5 '15 at 11:00

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.