0

I'm trying to set up wallpaper for my Windows 10 laptop. Basically, what should happen is the wallpaper should change to another (specific) image exactly on the hour. To do this, I downloaded this application.

However, I need to set a scheduled task to make it work.

If I manually run the application, then the wallpaper changes to the specified picture, no problem. But setting a task does not work. I'm very new to Windows, so I'm most likely doing it wrong.

Here's what I've got so far:

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

According to the Task Scheduler, the Next Run Time is 9:05:10 AM today, and the Last Run Time is 8:05:10 today. Both of these are right. But the program didn't run; my background is the same. For Last Run Result, it's giving me 0xE0434352, which I'm pretty sure is not correct (it should be 0x0 if it's successful, right?)

So it looks like the task is triggering, but not running the application.

How can I fix it so it runs properly?

  • Shouldn't the location be filled in the the directory containing DoctorWallpaper? – DavidPostill Oct 5 '15 at 15:31
  • Please edit your question to include screen shots of the other tabs. – DavidPostill Oct 5 '15 at 15:33
  • @DavidPostill I don't have enough reputation to add images, sorry; someone else edited it to add that one. You can see them here. And as for the location, I can't edit that for some reason. It won't let me paste, type, or delete the slash. – TheFirstQuestion Oct 5 '15 at 19:38
  • Your missing the "Action" tab :/ – DavidPostill Oct 5 '15 at 19:42
  • 1
    why don't just use the wallpaper slideshow which was already built-in? – phuclv May 12 '17 at 2:10
0

Try running it "only when user is logged on." Some things are isolated from one session to another, and "Run whether user is logged in or not" is less likely to be able to change things in the active user session.

Also try running the scheduled task with the highest privileges.

| improve this answer | |
  • Upon trying the application again, it appears that that no longer works. So perhaps the issue now lies with the application, not the task. – TheFirstQuestion Oct 5 '15 at 15:28
0

Try "for a duration of" 1 day instead of 1 hour

| improve this answer | |
  • This is correct. "For a duration of 1 hour" means the task turns off after 1 hour, and thus will not do anything again until scheduled again 24 hrs from the initial run. – kreemoweet Sep 12 at 20:59
-1

0xE0434352 is a general .Net exception and doesn't tell you much. You might find more information in the event viewer.

When scheduling make sure you fill in "Start in(Optional)" with the path of the executable you're running, sometimes programs will crash if you don't fill this in.

| improve this answer | |
  • What should I tell it to start in? – TheFirstQuestion Oct 5 '15 at 12:58
  • I added to the answer. If you're running C:\Example\Program\something.exe , the "Start in" should be C:\Example\Program\ – HoD Oct 5 '15 at 13:28
  • Still doesn't work. Thanks anyway. – TheFirstQuestion Oct 5 '15 at 15:26
-1

What helped me was to add some random description under the name instead of leaving it blank. hope it will help :DD

| improve this answer | |
  • Welcome to Super User. Your answer could use improvement by explaining why/how your solution fixes/addresses the OPs question and by adding detailed steps to implement your solution. – I say Reinstate Monica Apr 11 '17 at 18:43
  • OP is asking about setting a scheduled task in Windows 10 – yass Apr 11 '17 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.