Question-State: solved (not really but it basically works)

Edit (Current-Progress): ASUS released a new "BIOS-Update" (BIOS 210; Update FW) which fixes the "BIOS-Settings" issues, but I'm not sure if it also fixes the efibootmgr hard-bricking issues (I don't really want to test this, but theoretically it should). The ASUS support isn't cooperative at all and I guess they don't even understand the problem.

tl;dr - you might wanna just read "What happened", "The Issue" and "The Question"

Prologue:

I've recently bought an ASUS UX303LA-R4342H notebook, which is using an American Megatrends firmware (UEFI; Version: (UX303LAB.)207). I sadly ended up unexpectedly hard-bricking it after 11 days (it's fixed by now).

Since the firmware implements the UEFI-Specification I thought I'd use the UEFI-Implementation to manage the whole boot process instead of using additional software like GRUB2. As the "BIOS-Settings" don't offer an option to set boot parameters, which I needed for an external initramfs, I decided to use the program efibootmgr.

What happened:

I extracted the exact commands responsible for this from the history (/root/.bash_history):

342  efibootmgr --create --part 2 --label "Gentoo-Main" --loader 'kernel-genkernel-x86_64-4.0.5-gentoo.efi' -u initrd='initramfs-genkernel-x86_64-4.0.5-gentoo.img'
499  efibootmgr --create --part 2 --label "Gentoo-Patch" --loader 'kernel-genkernel-x86_64-4.0.5-gentoo_patch.efi' -u initrd='initramfs-genkernel-x86_64-4.0.5-gentoo_patch.img'
500  init 6

After command 342 I could reboot without problems, but after command 500 (reboot) my notebook didn't boot up anymore. When I pressed the power button it just displayed the ASUS-Logo and that was it (I couldn't access the "BIOS-Settings" with F2; pressing TAB sometimes removed the ASUS-Logo giving me a black screen with backlight; the power button still worked making it possible to shutdown; the keyboard-backlight was on). The program "efibootmgr" obviously shouldn't be able to hard-brick my notebook even if I would have entered a wrong command.

The Issue:

I'd say this failure is reproducible by adding two or three boot entries using efibootmgr, but I didn't test it so far as I don't wanna hard-brick my notebook again. - There are similar issues reported on Wikipedia. Instead I tried to execute efibootmgr just once with no other boot entries existing (you can find the command and the result here. Instead of creating just one entry this command created three visible entries in the "BIOS-Settings" under the boot section. I also decided to film it later but this time it only gave me two boot entries: https://youtu.be/5OS4i5eW4rU

As this didn't worked I decided to build the initramfs (I need this for my LVM2 root-fs) directly into the linux-kernel enabling me to use the "BIOS-Settings" to create boot entries. I thought this way there wouldn't occur any problems but I was wrong (again). Using the "BIOS-Settings" boot manager gave me completely wrong and inconsistent results as you can see here: https://youtu.be/25uiIpT3h4I

Current Situation:

My current situation is that I can't even save boot entries via the "BIOS-Settings" (idk why but they disappear after save&reboot (F10), however I can boot them once without saving).

I like the notebook itself (my only alternative was the Dell XPS 13 Developer Edition which is currently unavailable) and I don't really want to switch but the firmware seems just completely broken and I don't know anymore if it's a good idea to keep it. But if necessary I could try to use the CSM (legacy) mode in combination with GRUB2 (like with a traditional BIOS).

How ASUS thinks about this issue:

I already contacted the ASUS-Support but they don't seem to understand this problem. When I contacted them for the first time I described what happened using efibootmgr under GNU/Linux and they responded telling me that they don't support GNU/Linux ignoring my comment that this problem obviously isn't OS related. Later I contacted them describing how to cause it with the "BIOS-Settings" (without the use of GNU/Linux) and I'm currently waiting for a response.

I also contacted American Megatrends Inc. where I'm currently waiting for a response too.

The Question:

  • Am I getting something wrong?
  • Any suggestions what I can / should do about this?
  • Does somebody know a way to properly report this issue?
  • Would it make sense to contact Matt Domsch (the developer of efibootmgr) asking him for help (he's not responsible for this issue but since he wrote the original interface and apparently knows a lot about EFI / UEFI; he might also have some connections to related developers (ASUS/AMI))?

PS: This is my first post (question) here - I hope if formatted everything properly and followed the rules / guidelines, but if not please let me know (please let me also know if I there is something wrong, inaccurate, missing, etc.).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.