I'm running an up to date NVIDIA version 8.1.790.0, on Windows 10, with an EVGA GTX 980 Ti driving two ASUS 4k monitors through DisplayPort.

All works well until the system goes to power save if I have left the monitors on - then I move the mouse or touch a key and the system wakes, but only with one monitor. In graphics properties, only one monitor is available.

I can then go back into NVIDIA control panel, Set up multiple displays and I get the option to check the box for the 2nd monitor, and when I hit Apply changes, the 2nd monitor is enabled, and as long as I move something onto that monitor it remains on until the next time the system sleeps - if I don't move a window onto that monitor it sleeps again after 30 seconds or so.

I have googled for solutions, and looked on the NVIDIA forums but had no joy.

I have also seen this question but the top answers refer to AMD or Quadro cards (with different functionality)

  • Is the second monitor branched on DisplayPort? – harrymc Jan 14 '16 at 20:27
  • I have 3 DP ports. I have each monitor plugged into one. Haven't bought a 3rd one yet... – Rory Alsop Jan 14 '16 at 20:28
  • In the question you quoted, my answer involved disabling EDID auto-detect for NVIDIA. See this article for details. Have you tried it? – harrymc Jan 14 '16 at 21:24
  • Sadly it isn't offered as an option on this card. – Rory Alsop Jan 14 '16 at 21:25
  • 3 DP ports? According to the specs, GTX 980 Ti should have these three : HDMI, Dual Link DVI-I, DisplayPort. An application that it says set the EDID and so bypasses auto detection is Custom Resolution Utility - try it and see if you can set up a "Custom Resolution" that equals yours (I never used it). – harrymc Jan 15 '16 at 9:21
up vote 5 down vote accepted
+50

DisplayPort support in Windows is somewhat problematic. As it acts as a PNP device, powering it off may disconnect it from the computer as if it was removed and Windows may forget this device, until it is turned on again and is "discovered".

The problem is that Windows expects a PNP monitor to answer with its EDID at all times, and forgets it when the monitor does not answer. This process is also called Auto Detection.

The solution is to set the monitor's EDID for Windows as constant, so Windows will not try to contact the monitor.

If one has an NVIDIA Quatro display card, this can be done via the NVIDIA control panel.

One can also use a utility that creates a custom EDID profile, as these utilities set up a permanent profile in Windows so it does not contact the monitor.

Here are a couple of utilities :

  • Custom Resolution Utility
  • PowerStrip (shareware) was the best of its kind, but is not updated since 2012. It is still available for download (but no idea how long it will keep on working).

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.