18

I just upgraded to Mac OS X 10.11 (El Capitan) now pdflatex cannot be found.

I am using TexWorks to compile.

I get the error TeX may be installed I just need to find it.

Where can I find the install location? I checked the settings and TexWorks reports LaTeX was in /usr/bin or /usr/local/bin. How can I fix this issue?

TexWorks recommends me check /usr/bin.

  • 1
    Why the down vote? How can I improve the question? – Whitecat Oct 6 '15 at 18:20
22

Mine was moved to /Library/TeX/Root/bin/x86_64-darwin/pdflatex, hope that helps!

  • $ ls /Library/TeX/Root/bin/x86_64-darwin/pdflatex ls: /Library/TeX/Root/bin/x86_64-darwin/pdflatex: No such file or directory – Mona Jalal Sep 12 '17 at 2:48
8

If you are using homebrew, you'll get this message on the client:

Installing TeX from source is weird and gross, requires a lot of patches, and only builds 32-bit (and thus can't use Homebrew deps on Snow Leopard.)

We recommend using a MacTeX distribution: https://www.tug.org/mactex/

You can install it using Cask:

brew cask install mactex

So that's exactly what I'm doing. Using 'sudo' in front of the command, though, to facilitate installation.

After this, on pre-El Capitan systems, pdflatex would be found in /usr/texbin, however, with El Capitan, installations to /usr are no longer allowed. Hence, you will now find pdflatex and other related binaries in /Library/TeX/texbin. (Many thanks to the R-Bloggers website for this suggestion.) Just add this path to your $PATH env variable.

4

Yes. Mine moved to /Library/TeX/Root/bin/x86_64-darwin as well. I added this path in my TeXworks Preferences->Typesetting tab under the "Paths for TeX and related programs". Everything seems to be working as usual, though I have not yet checked raw tex and ConTeXt. But I guess things should be fine.

4

I use zsh and had to add /Library/TeX/texbin to my path in ~/.zshrc with:

export PATH="$PATH:/Library/TeX/texbin"

since zsh doesn't, apparently, use /usr/libexec/path_helper to load /etc/paths.d automatically and I didn't want to throw another variable into the equation by adding it (and all the other stuff in /etc/paths.d) without spending more time figuring out exactly what else that was going to do.

2

Just to mention that if you want to add the path in TexShop. The correct tab is "Engine"--"Path settings", and paste "/Library/TeX/Root/bin/x86_64-darwin" to the first input line.

Hope this helps.

1

TeXworks -> Preferences -> Typesetting

Click the + button for the first box and Choose the path of texbin which contain many file including pdflatex.

In my case this the path: /Library/TeX/Distributions/Programs/texbin

1

In my case, i typed a command "which pdflatex" at the terminal then it shows /Library/TeX/texbin/pdflatex. After that, i selected the option in the preferences as in this picture:

enter image description here

  • Welcome to Super User. This looks like a slightly different route to Raju Ranjan Kumar's answer. When you have a little more rep, it would probably be more appropriate to post minor variations to another answer as a comment, as it's intended that each answer provide a substantially different solution than what's already been contributed. – fixer1234 Oct 1 '16 at 19:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.