1

I am on Debian Jessie with Mate (v1.8.1) desktop environment.

I have installed byobu and wanted to launch it every time I open a terminal so I went into the profile preferences, checked Run a custom command instead of my shell and add the following command:
/usr/bin/byobu

It worked fine but I had the annoying startup message from byobu on each opening so I tried to mask the output by changing naively the command to:
/usr/bin/byobu > /dev/null

And here was my mistake... Now every time I launch a terminal it is closed immediately : I have no longer access to my profile preferences to edit the command. I do have access to Xterm though (i.e. I have a way to execute command lines).

  • How can I prevent the custom command to run on terminal launch ?
  • Where is stored the mate-terminal config file ? (so I can maybe manually removed the profile preferences)

P.S. I am aware of the --profile=PROFILE_NAME option of mate-terminal that I could launch from Xterm, unfortunately I have only one profile : the corrupted one.
I cannot find an option to launch mate-terminal with no preferences...

1

I couldn't find the location of terminal profile configuration file so here is what I did:

  • install dconf (GUI editor for desktop environment settings)
  • launch dconf-editor
  • Go to org > mate > terminal > profiles > profile0
  • edit the key "custom command" (set it to empty)

After that I was able to launch the terminal without executing my custom command and had access to profile preferences again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.