Windows 10 upgrades seems to have caused a myriad of touchpad-problems for users of several different laptop brands including Acer, Lenovo, Asus and others. But I have not yet found anyone with the same problem as me. -Surely I cannot be the only one with this problem?

When I click (on buttons, links etc) with my touchpad, the mouse-down event is triggered, but not the mouse-up event. -Not until the next time I move the mouse!

I have tried installing the win8.1 driver for the touchpad, and that kind-of works, except then the scroll-direction gets inverted and that is almost as annoying. (also, the win10 driver updates it self back in sometimes...)

I have also tried to find the unbranded elantech-driver for win10 64bit, but all I found was the Asus Smart Gesture with the same driver that came with the windows upgrade...

Computer: Asus Zenbook UX51VZ

Touchpad HW-id: ACPI\VEN_ETD&DEV_0105

  • Have you reported this problem to ASUS?
    – Ramhound
    Oct 6, 2015 at 14:31
  • Best solution I came up with is Windows 7 driver + blocking driver updates.
    – gronostaj
    Oct 6, 2015 at 14:31
  • I've had several issues with computers I've upgraded to Windows 7, even a blown ethernet card. I've found that the best way to fix all issues with it is to refresh Windows 10 and check to make sure all drivers are up-to-date once the refresh is done. That fixed all the issues I had, but make sure to have a backup display and ethernet/wireless driver on hand in case they get deleted. The reason I say refresh is because, in the upgrade, there are too many corruptions made by the installer to properly fix. Best of luck. Oct 6, 2015 at 14:40
  • @Ramhound Yes, I have reported it to ASUS, but I'm not holding my breath for a constructive response :P
    – Superole
    Oct 6, 2015 at 14:42
  • @Dooley_labs When you say refresh you mean download win10 installer to do a clean install instead of an upgrade?
    – Superole
    Oct 6, 2015 at 14:49

1 Answer 1


Since the question was made, ASUS released Elantech drivers for Win10.

You can find the latest Elantech driver here. However, I would suggest you to install the Smart Gesture driver which also includes the ELAN driver.

  • Hey Ivan, Your page is simply great! I visited it even before I posted this question :D And if I can just get this to work, I will accept this answer.
    – Superole
    Apr 14, 2016 at 10:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .