1

I have a problem with my laptop. I cannot connect to any RDP session while other laptops can do this. I also cannot connect to Microsoft Edge. I can connect to Google Chrome though.

When connecting tp an ip addres i got this error: An internal error has occurred When connecting to my terminal server (ts.xxx.info) I get the error: Remote Desktop cant find the computer "ts.xxx.info".

I searched in my firewalls, i restarted the remote desktop services, i restarted all the internet settings but nothing helped. It doenst matter if im in the domain or not, it both doenst work.

Does anyone have an idea what is wrong with my laptop? I am 100% sure that my dns is correctly configured because its the same as the other laptops. Any help is much appreciated

13
  • When you say the DNS is correctly configured does that imply this laptop has a static IP? – CharlesH Oct 7 '15 at 11:43
  • @CharlesH I tried a dynamic and static ip, but at the moment im using a static ip – user3201911 Oct 7 '15 at 11:46
  • Are you able to install the telnet client and telnet to a website or to one of these remote desktop servers from command prompt. Just in case you are unsure you install telnet client from add remove programs > Turn Windows Feature on or off... Then load command prompt and type Telnet www.google.co.uk 80 (the last number is the port so 80 for HTTP, 3389 for remote desktop)... – CharlesH Oct 7 '15 at 11:52
  • @CharlesH This is what i got: Connecting To www.google.com...Could not open connection to the host, on port 80: Connect failed and Connecting To 192.168.25.97...Could not open connection to the host, on port 3389. The requested service provider could not be loaded or initialized. – user3201911 Oct 7 '15 at 11:59
  • Sounds like the only thing left to do besides rebuilding the laptop would be to reinstall the network adapter to clear all settings and take it back to scratch. If you go to device manager, expand network adapters then right click the network adapter (might as well do all of them if it has wireless and Ethernet) and uninstall them. Then reboot and Windows should pick up the 'new' hardware and install them again... – CharlesH Oct 7 '15 at 12:12
4

Opening up an administrative command prompt and then typing

netsh winsock reset all

fixed the problem.

Credit goes to DavidPostill who gave me the solution via chat.

1
  • FYI: a restart may be required for the settings to go into effect. – Andrew Dec 12 '19 at 20:48
0

In my case this helped:

  1. Delete the MRU entries from the following registry: HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default
  2. Enter gpedit.msc in Start Search box.
  3. Navigate to User Configuration/Administrative templates/Windows components/Remote Desktop Services/ Remote Desktop Connection Client.
  4. In the right pane double-click on "Do not allow passwords to be saved" set to enabled. Then please restart. After re-log on, enable this policy again.

(from MS TechNet).

Error message you get possibly missleading. It makes you think something wrong with network connection to server, but it turns out that TS client has a problem with credential cache.

1
  • Nope, this didnt work\ – user3201911 Oct 7 '15 at 12:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.