14

I typically use Chrome, but recently tried giving Firefox another chance after not having used it in a year or two.

It has some nice features that make it very attractive over Chrome (like better management for many tabs open at once), but I have found performance to be absolutely terrible much of the time.

I go overboard with tabs sometimes so I expect it to suck memory, but I find that even with only a few tabs open it is frequently using 10% or even up to 30% CPU on the regular Firefox process or usually the Plugin Container process.

When this happens Firefox becomes very sluggish, for example it may take a second or so for words I type to appear in a text box. This typically happens after it has been open for a while. Killing the Plugin Container process and reloading the tabs or just restarting usually makes it better but only for a while.

This is across three different computers and still seems to happen with all non-essential add-ons and plugins uninstalled. One computer is a cheap laptop but the other two are high-performance machines with fast processors and Firefox still becomes unusable. It happens with updated versions of both regular and developer editions.

There also typically aren't any obvious demanding scripts running on any of the pages.

  • I have the same problem. Pale Moon didn't do this as much as Firefox does, but it's also incompatible with lots of extensions. – endolith May 7 '16 at 3:56
  • Please see superuser.com/questions/234923/… – UnclickableCharacter Jun 22 '16 at 20:39
  • 2
    Sometimes 60% to 70% cpu on a high-end core-i7 is what I am seeing in Linux. – JosephK Jul 23 '16 at 10:25
2

I have searched many places for a solution to this but nothing seemed to work. So I just opened the Options panel and took a look myself, like if it was the first time.

This solved it for me: Uncheck Options > Advanced > General > Browsing > "Check my spelling as I type"

  • This was already unchecked for me, and Firefox still uses plenty of cpu (Firefox 53.0, Ubuntu 14). – Camille Goudeseune May 8 '17 at 21:13
0

Try to see if you face the same problem when you try to run Firefox in Safe mode. If no then one of the add ons or extensions is the cause. You will have to disable the add ons and extensions one by one and see if it improves your performance.

If however even in Firefox safe mode you are having issues then the problem will most probably be with the computer. You can try to do the following few items. The list given below is not comprehensive it will point you in the right direction.

  • Open windows task manager (Shortcut key CTRL+SHIFT+ESC), when Firefox is running and sort applications based on "Working Set (Memory)". Check what is consuming the maximum amount of RAM and see if you can live with closing that particular program. Look at the top 5-10 memory hogs and close those applications which you do not use. By default the "Working Set (Memory)" will not be available. You will have to go to View > Select Columns and then get this value.
  • Again with Windows Task Manager open sort the programs by "I/O Write (Bytes)". Look at the programs or services which are doing the most "I/O Write (Bytes)" and see if you can close them. This is especially important if you are using a SSD because of a concept called as Write Amplification. By default Windows Task manager does not display "I/O Write (Bytes)". You will have to go View > Select Columns and then get this option. Another point to look at is whether you can see the disk activity LED light up when you are using Firefox. If that is the case then there might be massive disk thrashing going on when you are trying to run Firefox.
  • Check if your HDD is Fragmented. If you are running a SSD then please be careful.
  • Check for free space on the HDD/SSD which has your page file system. It should not be getting full. If it is then see if it is possible to move Windows Paging file to a partition or HDD which has more free space and which will not fill up.
  • Check for free space on the partition where Firefox profile folder is kept.
  • Check if your CPU Fans are working fine and your CPU is not getting throttled. I have seen cases especially in old DELL laptops which would throttle CPU's. So for example if one has core 2 duos running 1.66 GHz, only one core would run on 1.66 Ghz and the other would run at 900 Mhz thus impacting the performance of the machine.

I am assuming that you have sufficient RAM on your computers, have an upto date virus definitions and firewall in place.

  • 1
    Thanks. Definitely when experiencing this problem checking the task manager is the first thing I do. Pretty much always Firefox only using any CPU. Usually nothing using much disk access but of course I don't blame Firefox if it turns out Windows Update is currently maxing it out. Free space is fine on all computers, one is actually brand new with like 5% used. Definitely not because of page file, have 16gb and 32gb memory on 2 machines and I'm typically nowhere close to that. I don't think CPU throttling or fans are the culprit, I frequently run some pretty heavy scientific computations. – JaredL Oct 9 '15 at 6:40
  • Think I'll try safe mode during work tomorrow, I know I had all installations synced at one point and maybe there's something in my account that's causing it. If that doesn't do it I'll try a fresh reinstall and not syncing afterward. – JaredL Oct 9 '15 at 6:42
  • "Look at the top 5-10 memory hogs" Firefox is always the number 1 memory hog. – endolith May 7 '16 at 3:54
  • 3
    A totally fresh (< 5 hours) installation of a brand new N3700 W10 workstation: Keyboard almost unusable in Gmail when using Firefox. Works perfectly in Chrome. Even in the background Firefox is using 10-25% of CPU and peaks to 100% on one CPU core. Firefox memory usage 750 MB with all but one tabs closed. All this started about a year ago with another low-end computer, hence the switch to a new one. But the culprit was and still is FF and there seems to be nothing one can do about it. – karvonen Jun 1 '16 at 8:13
  • 1
    Chrome (total spyware) is not an option for anyone with a grasp of history - we fought and won the cold-war, only to install East Germany's totalitarian tracking dream on our PCs?. Disable the FF add-ons, and it is unusable - many are necessary to get back the way it "used to work" before they broke it. Wish we could just get FF v 3.5 with security patches, that would fly on a modern machine. – JosephK Jul 23 '16 at 10:27
0

Try installing the NoScript extension for FireFox. This will give you more granular control over the often CPU-hungry client-side code that loads and keeps running long after the web page has finished downloading to your computer. The following StackOverflow article gives some more info on the benefits of client side Javascript manipulation: https://stackoverflow.com/questions/28377723/how-to-monitor-and-or-throttle-rate-limit-cpu-bandwidth-by-client-side-web-pages

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.