My Windows 7 (x86, Pro) laptop no longer hibernates. When I tell it via power button or "shutdown /h /f" it fades out the screen to black, but doesn't do anything else. Doesn't even go into a sleep state. Hitting a key pops the screen back on.

I've tried disabling and reenabling hibernation to clear the hiberfil.sys, but it makes no difference. If hibernation is disabled, sleep works fine.

This problem started happening immediately after swapping hard drives. I used Ghost 14 to restore a backup to a new drive then plugged it in. Windows wouldn't boot (BOOTMGR problem) so I ran a repair from the Win7 disc. It's been working fine since, aside from inability to hibernate.

Nothing is showing up in the event log that seems new or relevant.

Any ideas on how I can diagnose or resolve this?


4 Answers 4


It turned out to be some kind of problem with the boot partition. While Windows booted fine and showed no problems in the event log, running the Win7 "startup repair" did find and repair problems. Once this was done, the machine hibernated fine again. (shrug)


You could try this troubleshooting tutorial. It's for Vista but should also work for 7.


I had the exact same problem. After cloning my old hard disk to a new disk using Clonezilla, the computer booted and worked fine, but hibernate did not. Screen was going black, but it never hibernated - moving the mouse would bring it back to the desktop.

The first thing I noticed was the default operating systems was blank in the dropdown here:

Start > right-click Computer > Properties > Advanced System Settings > Startup and Recovery Settings > System Startup

This pointed to a problem with the boot partition.

To fix this I used Disk Management (Start > right-click Computer > Manage > Disk Management) to set the C drive (the second partition after the small 100Mb or so one) as Active.

Immediately restarted and used Windows 7 DVD to boot. Click Repair, and use the Startup Repair wizard to find and fix the problem.

This time, when rebooted I got BOOTMGR is missing.

I then booted a second time using Windows 7 DVD, used the Startup Repair wizard again.

On the next boot, Windows started normally, and now Hibernate works.

I can only think the clone operation corrupted the boot partition somehow - not enough to stop Windows booting though. It seems Startup Repair needs to be run twice to totally repair the partition and bootloader after setting C drive as an Active partition.

Hope this helps someone else, as it's taken me all day to sort this out :)


As in the answer given above, I noticed a blank default operating system entry in Advanced System Settings > Startup and Recovery Settings > System Startup

I also noticed that in "System Protection" / "System Restore" disk C was listed twice, one entry was listed as "missing".

Removing this entry by turning off system restore solved all problems (not true, see P.S.2):

The default operating system was listed as "Windows 7" again and hibernate also worked again. (Of course it had to be enabled: powercfg -h on)

P.S.: I had tried the startup repair, but that failed with error 0x490.

P.S.2: In the end the problem was this: On this Dell laptop there were three partitions, a 39 MB "OEM" partition, a 14 GB recovery and boot partition and the C:\ partition. Before the clone the 2nd boot partition had no drive letter but the label "RECOVERY". After the clone, it had no drive letter and no label. Either assigning a driver letter or a label fixed the problem. Obviously I went for assigning the label "RECOVERY" again and not having a driver letter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.