14

I have a 64 bit Windows 7 with VirtualBox running the same 64 bit Windows 7 as a guest OS.

When I set a specific date and time, it will always revert to the host OS’s date and time on startup. How can I disable this?

15
  1. Find the location where your Virtual Machine is stored. You can do this by right clicking on the machine from the list in the VirtualBox Manager and selecting Show in Explorer

Find Machine Source Path

  1. Backup the file called yourVMname.vbox

  2. Open the file in a text editor and navigate to the <ExtraData> element which should contain a list of ExtraDataItem elements

  3. Add the following item to the list: <ExtraDataItem name="VBoxInternal/Devices/VMMDev/0/Config/GetHostTimeDisabled" value="1"/>

  4. The final section should look something like this:

Final Edited VM Configuration

source

  • 1
    Vbox show me issue with first quotation mark you have used. After I type it manually it worked. – Hareen Laks Nov 11 '16 at 13:04
  • 1
    I did it on Mac, it worked. I just replaces VBoxInternal by VBoxInternal2. – AnthonyB Apr 24 '17 at 15:23
  • 1
    VirtualBox should be restarted. – Alex78191 Jul 17 '17 at 8:27
13

The command to disable time synchronization between host and guest in Virtualbox is:

VBoxManage setextradata "VM name" "VBoxInternal/Devices/VMMDev/0/Config/GetHostTimeDisabled" 1

See the Virtualbox manual, section 9.14, especially 9.14.4.

Note that in a Windows host your command window's default directory must be in the directory where Vboxmanage.exe exists (default: C:\Program Files\Oracle\Virtualbox) or you have to type the full path to Vboxmanage.exe.

  • Also vagrant reload after running that set command. – Cees Timmerman Jun 11 at 9:25

protected by Community Aug 13 at 14:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.