11

Ever since my upgrade from Windows 8.1 to 10 (and a healthy amount of Chrome updates that followed) I can't seem to get the old running in the background feature back that came with the Chrome Notification Center. I know deliberately wanting to have something running in the background sounds odd, but I liked it because I got the notifications from installed extensions even after I had closed every browser window. Additionally, it made the browser itself open faster (e.g. not having to re-initiate all extensions after an accidental close).

Is this something that has to do with Windows 10 or this functionality was removed from Chrome itself? And if neither, how can I get it back?

Clarification:
The Chrome icon is not in the notification area, and the option to allow running apps in the background is checked. Those were the suggestions I found on my own when searching for a solution, but it did not help.

10

Looks like all it takes to get it to show up is have a background app installed. I used to install Dropbox for Gmail to get this functionality, but after seeing how many permissions I have to grant just to have Chrome running in the background I decided to uninstall it and make my own open source extension: Lightning Reopen.

Same effect, none of the unnecessary permissions.

| improve this answer | |
  • Excellent. Thank you for making this available. This also has the added bonus of keeping sessions alive / session cookies are not discarded. This is especially useful if you are in and out of a website a lot, but just want to close the page when you're done (like in the olden days). – Ken Sharp Feb 28 at 14:19
5

Google chrome > three points in the right side top > Setting > Show advanced settings…

scroll down

system > continue running background apps when google chrome is closed

| improve this answer | |
  • I just quit the icon and could not make it appears again. Your solution solve my problem perfectly, thank you! – ncenerar May 11 '17 at 7:29
  • This is the only correct answer here. These other application suggestions shouldn't be marked correct. – Jim Stewart Aug 24 '18 at 18:59
  • 1
    @JimStewart The question being asked explicitly states that this option was checked for me, which means it did not solve the issue. That's why it was not marked correct. – SeinopSys Aug 24 '18 at 19:35
2

I had to install an app that runs in the background, so I installed Checker Plus, an app that's actually very useful if you have a Google email account. As long as you check "Run in background when google chrome is closed" under the "notifications" settings tab you should get the fast boot times of Chrome.

Opening Google Drive used to work but now doesn't which is a shame.

| improve this answer | |
1

In your notification center, you should see the Google Chrome icon.

Right click it and check the 'Let Google Chrome run in the background' option.

enter image description here


If you can't see the Google Chrome icon in your notification center:

  • Check that Chrome is running in the background: Manage background pages and apps
  • Check the taskbar visibility settings for the Chrome icon: Start > Settings > System > Notifications & Actions > Select which icons appear on the taskbar
| improve this answer | |
  • 2
    I'm not seeing that icon on the taskbar, not even when clicking the arrow. I'm certain I did not disable the icon in any way, it's just not there. – SeinopSys Oct 8 '15 at 20:56
  • 1
    You don't have that icon until you enable the option in settings, per @El-Fekey above. – Jim Stewart Aug 24 '18 at 19:00
  • 1
    You only get the icon if you actually have a background app installed. Otherwise: what on Earth would be the point? – Ken Sharp Feb 28 at 14:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.