1

SHORT:

How to switch between docs/tabs by side clicking mouse's scroll wheel?

LONG:

I updated Notepad++ to 6.8.3 and lost the abliity to switch tabs by clicking the mouse scroll wheel to the left or right.

I recall this happening on a previous update, and I think I had to re-map the relevant scroll wheel shortcut to get it going again. I don't update often, so it has been a while.

This time, however, I have not been able to figure out how to map right/left-scroll-wheel-click. The scroll wheel does not seem to be an option. Just a combination of ctrl + alt+ shift and a key list. Perhaps they changed this since I last checked, or perhaps I did something differently. I don't know.

Can anyone help?

UPDATE

As per David Metcalfe's answer below, tilt wheel is not available in Notepad++ and an autohotkey script is an option.

But if you lost this functionality (switching between tabs by using the mouse tilt-wheel-click / scroll-wheel-side-click) you can probably restore without installing AHK etc.

My issue was caused by one of either two things, each with their own "fix".

Either:

  1. I had personal mappings that hadn't been imported to the new version; or
  2. The new version reset my mappings.

I don't know because it is now fixed, and I couldn't be bothered checking what fixed it.

If your problem is the same as mine, to fix will be either one of these:

First, if personal mappings hadn't been imported, this should do it:

  1. Simply close NPP and reopen it.

If that doesn't work, then mappings has probably been reset so:

  1. Open Notepad++ and go to Shortcut mapper (Settings > Shortcut Mapper)
  2. Go to line ~151 "Next Tab" - assign "Ctrl+PageDown" buttons
  3. Go to line ~152 "Previous Tab" - assign "Ctrl+PageUp" buttons
  4. Apply changes.

If that doesn't work, check that your not using the alternative "Ctrl+Shift+Tab" and "Ctrl+Tab" tab switching on your mouse by:

  1. Going to your mouse settings via your operating system
  2. Check that "Ctrl+PageDown" has been assigned to click from left side (ie NEXT)
  3. Check that "Ctrl+PageUp" has been assigned to to click from right side (ie PREVIOUS)
  4. Close Mouse Settings

When you reopen NPP and it should be working again.

NOTE You probably could use "Ctrl+Shift+Tab" and "Ctrl+Tab" but they cause a switch via that annoying scroll menu.

2

The only information I can locate about this is various people who wanted to remove similar functionality to what you describe, and all resulting commentary suggests this functionality was unexpected.

If we assume the above to be true, the only thing I could guess at is if Notepad++ has a config file, adding or removing keys, etc. from the Shortcut Mapper might be possible. Alternatively, you could always use AutoHotkey to have your Mouse Left/Right (assuming you have a tiltwheel mouse) to perform the Ctrl+Page Up/Down actions when Notepad++ is the active window.

If you are interested in such a script, please let me know and I'll edit this answer accordingly.

  • 1
    I think we have reached a similar conclusion: the ability to map the tilt wheel in Notepad++ has been removed since my last version. I will mark your answer as correct given the absence of any information to the contrary here and generally. . I also thank you for your kind offer of an AutoHotKey script, but I will pass on this and instead just try get by on the keys. – TBB Oct 11 '15 at 6:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.