3

I'm trying to turn "num lock" on when windows starts up, at login time. (I have Windows 10).

I edited the registry at the following path:

HKEY_USERS\Default\Control Panel\Keyboard\InitialKeyboardIndicators

to

2147483650

and when I restart the computer, num lock is not on by default. What am I doing wrong, and how can I fix it?

I have a HP Compaq 6000 Pro microtower.

5
  • @DavidPostill That did not solve my problem. – Steve Oct 11 '15 at 8:20
  • 1
    Did you miss the answer that said "There is also a 'boot with numlock on' setting in most modern bioses."? – DavidPostill Oct 11 '15 at 8:24
  • I just tried that. The bios menu is different in windows 10. I couldn't find one that let's you change the numlock setting. – Steve Oct 11 '15 at 8:33
  • What is the make and model of your PC? What is the manufacturer listed in the BIOS? – DavidPostill Oct 11 '15 at 8:35
  • hp compaq 6000 pro microtower – Steve Oct 11 '15 at 8:40
0

I'm trying to turn "num lock" on when windows starts up

HP Compaq 6000 Pro microtower

  • Press F10 to access Setup.
  • Goto "Advanced" > "Device Options".
  • Enable "Num Lock".

    enter image description here


Using Computer Setup (F10) Utilities Computer

Setup can be accessed only by turning the computer on or restarting the system.

To access the Computer Setup Utilities menu, complete the following steps:

  1. Turn on or restart the computer.

  2. As soon as the computer is turned on, press F10 when the monitor light turns green to enter Computer Setup.

    Press Enter to bypass the title screen, if necessary.

    Note: If you do not press F10 at the appropriate time, you must restart the computer and again press F10 when the monitor light turns green to access the utility.

  3. Select your language from the list and press Enter.

  4. A choice of five headings appears in the Computer Setup Utilities menu: File, Storage, Security, Power, and Advanced.

Source HP Compaq 6000 Pro All-in-One PC - Computer Setup (F10) Utility

1
  • Thanks! I was using f8 instead of f10, so nothing would come up. I thought it was because windows 10 changed things. But anyways thanks! It's working now! – Steve Oct 11 '15 at 17:12
2

There are three levels for such settings in the registry and you need to set InitialKeyboardIndicators value to 2 under all next keys:

  • settings in HKEY_USERS\.Default alias HKEY_USERS\S-1-5-18 are used by programs and services that run as Local System (as S-1-5-18 is the security identifier for the Local System account). Important for logon screen/dialog as winlogon.exe runs under SYSTEM account.
  • settings in HKEY_CURRENT_USER are valid for currently logged user.
  • (facultative) settings in HKEY_USERS\Default are the basis for new user profiles (not loaded most of the time; the hive loadable manually from C:\Users\Default\NTUSER.DAT).

For instance, next settings should work as expected:

==> reg  query "HKU\.DEFAULT\Control Panel\Keyboard" /V InitialKeyboardIndicators

HKEY_USERS\.DEFAULT\Control Panel\Keyboard
    InitialKeyboardIndicators    REG_SZ    2

==> reg  query "HKU\DEFAULT\Control Panel\Keyboard" /V InitialKeyboardIndicators

HKEY_USERS\DEFAULT\Control Panel\Keyboard
    InitialKeyboardIndicators    REG_SZ    2

==> reg  query "HKCU\Control Panel\Keyboard" /V InitialKeyboardIndicators

HKEY_CURRENT_USER\Control Panel\Keyboard
    InitialKeyboardIndicators    REG_SZ    2

==>

FYI, 2147483648 = 2^31 = hexadecimal 0x80000000 (it sets the highest weight bit on in 32-bit integer arithmetic) seems to be a default value since Windows 2000 times, maybe erst. Some estimate that this value means do not override current LOCK status. However, I have experienced another behaviour and therefore keep switching to above settings.

See also CEPtor's post on July 1, 2010 at answers.microsoft.com:

It is important to use the find function to locate ALL keyboard keys for InitialKeyboardIndicators and set them to the same value setting. The value options are as follows:

  • 0 - Turn all indicators Off (NumLock, CapsLock, ScrollLock)
  • 1 - Turn CapsLock On
  • 2 - Turn NumLock On
  • 3 - Turn CapsLock and NumLock On
  • 4 - Turn ScrollLock On
  • 5 - Turn CapsLock and ScrollLock On
  • 6 - Turn NumLock and ScrollLock On
  • 7 - Turn all indicators On (NumLock, CapsLock, ScrollLock)

Warning: change only numeric InitialKeyboardIndicators values; keep those under HKEY_LOCAL_MACHINE referring to something like USR:Control Panel\Keyboard

1
  • Thanks you Yosef! (And no, that wasn't a mistake!) It was easier to just do it with the bios. – Steve Oct 11 '15 at 17:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.