0

I am running a IP PBX system with trixbox, what i'm trying to do is connect PSTN lines with IAX2 using X100P analogue card.

The problem is i cannot call any outgoing routes. (already tried AsteriskNOW and elastix)

The problem as i've learned is "low IRQ"(Interrupt Request), if that is the case how do i increase it? or am i missing something.

I read all the documentations and still the problem exists, if anyone has any idea about IRQ then please help me.

The error while i try to call out is what mentioned in the title.

Any help would be appreciated.

0

My response is (informed) speculation based on years running an ISP in the days of modems, and also having used [ and sold ] X100P cards - however I have not run across your problem - I answer because I suspect most people havn't come across this - particularly as with the rise of VOIP, X100P cards are - at least in my part of the world - largely a thing of the past.

An X100P card is actually just a specific Windows / Soft Modem, ie a modem with cut down firmware - which Digium wrote a driver for and can be controlled sufficiently by Asterisk.

The problem is probably that you don't have any free IRQ's to be assigned to the modem. The first thing I would try is loading your BIOS and disabling devices which you don't use - for example Floppy disk drive, but more importantly, any serial or parellel ports if you have them.

If that fails, you should try adding the command "pci=routeirq", or, if that fails, "pollirq" to the boot line of your kernel. (If you don't know how to do it, thats a seperate question - we would need to know the distro and version you are running - and, if you know it, which boot loader). Here is an old, but possibly useful post related to this paragraph.

|improve this answer|||||
  • tried both commands in grub, unrecognized command. what should i do? the system cannot establish a connection with my X100P card. i've at this for weeks help me please.... – Account Unknown Oct 18 '15 at 7:14
  • i am 100% sure this is IRQ problem, i was working around the server and suddenly for no reason (i don't remember what i did, might have pulled the line out and connected again) IRQ level spiked to max level, and the error gone. but still i can't make calls. how do it increase IRQ? do i have to use older asterisk version? please help – Account Unknown Oct 18 '15 at 8:01
  • Just to make sure something clear, where should type those commands? – Account Unknown Oct 18 '15 at 9:10
  • got it... not sure your answer helped me... solved by myself... thanks anyways... – Account Unknown Oct 18 '15 at 10:46
  • @AccountUnknown You should publish how you solved it, to help someone who in the future could have the same problem. – jcbermu Oct 19 '15 at 13:20
0

Like i said it's the IRQ, Interrupt Request. the X100P devices makes lot of requests so it needs to be on higher IRQ. Try changing PCI slots or motherboard. Once you have enough IRQ to make and receive calls "Don't remove it". That's it.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.